If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

paragraphs are offsets like 1px vertically in the middle (screenshot provided)

RESOLVED WORKSFORME

Status

()

Core
Layout: View Rendering
--
minor
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: pascalc, Assigned: roc)

Tracking

({regression, top100})

Trunk
x86
Windows XP
regression, top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed?], URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
build 2003041508 WInxp

go to http://fr.news.yahoo.com/32/

Look at the paragraphs, the first ones are like vertically broken with a 1px
offset, this is most noticable on links which underlining ends up 1 pixel lower
than it had started.

This is a recent regression.
(Reporter)

Comment 1

15 years ago
Created attachment 120717 [details]
screenshot
(Reporter)

Comment 2

15 years ago
Still seeing it on all yahoo news pages with build 2003042208
yahoo is a top100 website, adding keyword
Keywords: top100
Some sort of invalidation issue?
Assignee: font → roc+moz
Component: Layout: Fonts and Text → Layout: View Rendering
I don't see this on Linux. Does anyone?
(Reporter)

Comment 5

15 years ago
I found the cause for my bug, I have a CSS rule in userContent to opacify
banners and the problem disappears whe your remove the rule:


[src*="/ads."], [src*="/ads/"],
[src*="doubleclick"],
[href*="doubleclick."] *,
[href*="rd.yahoo.com"] [src*="yimg.com"],
[width="60"][height="468"],
[width="468"][height="60"],
[width="120"][height="600"]
{
	-moz-opacity: 0.1;
}

[src*="/ads."]:hover, [src*="/ads/"]:hover,
[src*="doubleclick"]:hover,
[href*=".doubleclick."] *:hover,
[href*="rd.yahoo.com"] [src*="yimg.com"]:hover,
[width="60"][height="468"]:hover,
[width="468"][height="60"]:hover,
[width="120"][height="600"]:hover
{
	-moz-opacity: 1;
}

So it appears that the problem is in -moz-opacity

Comment 6

14 years ago
Pascal, I tried the url with and without your userContent.css and don't see the
problem in a recent 1.7 trunk build on winxp. Do you still see it with a recent
Mozilla build?
Whiteboard: [fixed?]
(Reporter)

Comment 7

14 years ago
I no longer see te bug with build id 2004032208, marking WFM
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.