image in frames rendered mis-assembled

VERIFIED FIXED in M13

Status

()

Core
HTML: Parser
P3
major
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: blee, Assigned: harishd)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
To see this, visit the page in URL above.
==> The images of four frames show up unmatched in broken pieces.

bld: Linux 11-29-08-M12.

Comment 1

18 years ago
Created attachment 3096 [details]
Reduced test case

Comment 2

18 years ago
I created a reduces test case, but unfortunately the reduced test case displays
correctly most of the time

Updated

18 years ago
OS: Linux → All

Comment 3

18 years ago
Narrowing it down a little. The problems seems to be the 'A HREF="/imac"' that
is displayed.

Dumping of the content model shows this:

  body@00ECCCCC bgcolor=white refcount=3<
    Text@00EE0678 refcount=3<\n\t\t>
    Comment@00EE06F0 refcount=2<!-- START TITLE -->
    Text@00EE0870 refcount=3<\n\t\t>
    table@00EE08F4 width=600 border=0 cellpadding=0 cellspacing=0 refcount=6<
      tbody@00F48E84 refcount=3<
        tr@00EE0B34 refcount=3<
          td@00EE0C98 width=600 valign=Top align=Left refcount=4<
            Text@00EE0F88 refcount=3<\nA HREF="/imac/">>

That explains where 'A HREF="/imac"' comes from

Updated

18 years ago
Assignee: troy → harishd
Component: Layout → Parser

Comment 4

18 years ago
Looking at the source HTML I see this:

<A HREF="/imac/"><IMG SRC="http:

and so it appears that somewhere along the way the '<' gets lost.

Looks to be a parser issue so assigning to Harish so he can take a look.

Harish: ignore my reduced test case and load http://www.apple.com from the Web.
I couldn't reproduce the problem when I used a local copy of the Web page

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 5

18 years ago
Fixed in my tree awaiting opportunity to check in.

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 6

18 years ago
Fixed by update to elementtable.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 7

18 years ago
With the latest build (2000010308), the problem appears to be fixed.
You need to log in before you can comment on or make changes to this bug.