Trying to open the Java console window crashes Mozilla

RESOLVED WONTFIX

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED WONTFIX
15 years ago
7 years ago

People

(Reporter: Doug Brann, Assigned: Patrick C. Beard)

Tracking

({crash})

Trunk
DEC
OpenVMS
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (X11; U; OpenVMS AlphaServer_4100_5/533_4MB; en-US; rv:1.3) Gecko/20030313

Java Plugin info:

Java(TM) Plug-in 1.4.0-1

    File name: libjavaplugin_oji.so
    Java(TM) Plug-in1.4.0_03


Error messages:

GENERIC_POLL: unknown condition, errno=4 vaxc$errno=2096
INTERNAL ERROR on Browser End: Could not read ack from browser
System error?:: interrupted system call


Our machine is running DEC TCPIP Services if that matters.

VMS version: OpenVMS V7.2-2

Reproducible: Always

Steps to Reproduce:
1. Tools..Web Development..Java Console
2.
3.

Actual Results:  
Mozilla crashes with teh message in the details section.

Expected Results:  
Opened the Java Console
Have you copied the plugin or symlinked ?
(copy is wrong)

no plugin written in Java -> Oji
Assignee: idk → joshua.xia
Component: Java-Implemented Plugins → OJI
QA Contact: avm → dsirnapalli
(Reporter)

Comment 2

15 years ago
symlinks do not exist on VMS.  I did try copying in a fresh copy of the plugin 
from our SDK 1.4.0-1 distribution; neither worked.

Updated

15 years ago
Keywords: crash
OS: other → OpenVMS
Hardware: Other → DEC

Comment 3

15 years ago
Are you using the full SDK or just the JRE?
(Reporter)

Comment 4

15 years ago
In this  case it was the JRE. 

Comment 5

15 years ago
Then I think you're getting bitten by a problem which was just discovered the
other day. Basically the JRE kit is missing one file. See bug 199932 comment 11
for details.

I have just posted a copy of the missing file to bug 199932. Please try it, and
let me know if this fixes the problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

15 years ago
We were already aware of this problem and had added this file to our JRE 
before reporting this problem.

Comment 7

15 years ago
Are any TRACE files are left behind in your SYS$LOGIN directory?
(Reporter)

Comment 8

15 years ago
I currently only have access to email.  I'll look either later tonight or 
first thing in the morning.
(Reporter)

Comment 9

15 years ago
Here is the trace and it looks very much like the problem we were seeing 
running Java by itself before adding the missing file.

java.lang.NullPointerException
        at sun.awt.X11GraphicsEnvironment.addPlatformNameForFontProperties
(X11GraphicsEnvironment.java:519)
        at sun.java2d.SunGraphicsEnvironment.initTerminalNames
(SunGraphicsEnvironment.java:938)
        at sun.java2d.SunGraphicsEnvironment.initCompositeFonts
(SunGraphicsEnvironment.java:778)
        at sun.java2d.SunGraphicsEnvironment.access$100
(SunGraphicsEnvironment.java:58)
        at sun.java2d.SunGraphicsEnvironment$1.run
(SunGraphicsEnvironment.java:162)
        at java.security.AccessController.doPrivileged(Native Method)
        at sun.java2d.SunGraphicsEnvironment.<init>
(SunGraphicsEnvironment.java:87)
        at sun.awt.X11GraphicsEnvironment.<init>
(X11GraphicsEnvironment.java:155)
        at java.lang.Class.native_newInstance0(Native Method)
        at java.lang.Class.newInstance(Class.java:251)
        at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment
(GraphicsEnvironment.java:62)
        at java.awt.Window.init(Window.java:224)
        at java.awt.Window.<init>(Window.java:268)
        at java.awt.Frame.<init>(Frame.java:398)
        at javax.swing.JFrame.<init>(JFrame.java:198)
        at sun.plugin.ConsoleWindow.<init>(ConsoleWindow.java:68)
        at sun.plugin.JavaRunTime.getJavaConsole(JavaRunTime.java:100)
        at sun.plugin.JavaRunTime.showJavaConsole(JavaRunTime.java:184)
        at sun.plugin.AppletViewer.initEnvironment(AppletViewer.java:290)
        at sun.plugin.navig.motif.Plugin.doit(Plugin.java:152)
        at sun.plugin.navig.motif.Plugin.start(Plugin.java:96)

Comment 10

15 years ago
OpenVMS->beard@netscape.com
Assignee: joshua.xia → beard

Comment 11

15 years ago
The java stack trace is identical to the "missing fonts_dir.dat" file problem. I
have to ask the obvious, are you 100% sure that you now have the correct
fonts_dir.dat file, in the correct place, and with the correct file attributes?

Do you have an OpenVMS support contract, because this is a Java problem, and
we're going to need to get the Java folks involved?
(Reporter)

Comment 12

15 years ago
Thank you for asking the obvious.  I just discovered that for performance 
reasons for our testing folks we have a duplicate install of our software on 
the machine where Mozilla 1.3 is installed so it was using a different copy of 
the JRE than the one where I had added the missing file.  One the file was 
added on this machine, the console starts and our applet is executing.

Thanks much!

Comment 13

15 years ago
Glad to hear it. Closing report.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.