If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

On local drive web pages, link "\" are not converted to "/", and the link fails

RESOLVED INVALID

Status

SeaMonkey
Location Bar
RESOLVED INVALID
15 years ago
9 years ago

People

(Reporter: William.Campbell, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401

In my HTML pages, I created links in the form:
".\Early Fischer\frametop.htm"

If I bring up Mozilla on the root file, say:
"K:\SD_PICS_WORKAREA\Disc1\index.htm", the page loads OK but in the
URL bar it shows "K:/SD_PICS_WORKAREA/Disc1/index.htm".
Apparently it converts it to Unix style slashes. But when I then
click on a link from the index.htm file (like the like above)
I get an error from Mozilla that says it cannot find the page:
"/K:/SD_PICS_WORKAREA/Disc1/.\Early Fischer\frametop.htm".

I went and changed one of the files to use only the the forward
slash, and Mozilla was OK. This original unmodified identical code
works just fine on IE. (IE also doesn't change the original back
slashes to fowards slashes, and if I edit the link to have forward
slashes, it changes all slashes to back slashes.)

This may be related to the several levels of indirection, I was
unable to duplicate this with a one directory level of indirection.

Reproducible: Always

Steps to Reproduce:
1. See the details section
Actual Results:  
Mozilla says it cannot find the page

Expected Results:  
converted all backslashs in the link to forward slashs
before appending it to the current URL path.

I can send a zip file of a small project that duplicates this
error if desired.

Comment 1

15 years ago
*** Bug 202318 has been marked as a duplicate of this bug. ***
a "\" is invalid in an URL. The URL Bar corrects such an invalid URL if you
enter it in the URL Bar but Mozilla will not convert illegal URLs in the
document itself.

Use "file:///K:/foo/bar.html" instead 

>This original unmodified identical code
>works just fine on IE.

That is a bug (They call it feature) in IE.
read http://www.ietf.org/rfc/rfc2396.txt for more informations

-> invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
i forgot : that's section 2.4.3 in the RFC
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.