Composer close when Menu: File\Close

RESOLVED DUPLICATE of bug 117273

Status

SeaMonkey
Composer
--
minor
RESOLVED DUPLICATE of bug 117273
15 years ago
13 years ago

People

(Reporter: Martin Bohm, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

When only one file is opend in Compser, the command "File\Close" close the file
AND the composer. It's unexpected. I expected, that only the current file is closed.
The Composer itself has to close with the Command "File\Exit" only.
When the last file in Composer is closed, the Composer could show a empty,
untitled page as on startup.

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
Duplicate of bug 117273.
Summary: Composer close when Menu: File\Close → Composer close when Menu: File\Close

*** This bug has been marked as a duplicate of 117273 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Comment 3

13 years ago
I understand that Composer window is intenionally closed when the document is closed, but this in unexpected behavior.  The window should remain open, and blank, just as it is when Composer is selected from the Window menu of Mozilla.  Opening the document should re-read the file, in case changes were made to the file using a text editor.  This might happen in the case where one is trying to adjust the size of images, a feature that does not work, by the way, in 1.7.12.
You need to log in before you can comment on or make changes to this bug.