the whole page displayed only and entirely chinese characters

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: kmiers, Assigned: asa)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/1.3 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

Yes- this entire url display - the entire page! was totally full of chinese characters, when it should have showed - if viewed in int explorer - the entire (normal!)  "www.wheretodance.co.nz" website.

I am not impressed with mozilla:; how can u screw up so badly??
kmiers@world-net.co.nz

Reproducible: Always

Steps to Reproduce:
1.mozilla version 1.3
2.enter "www.wheretodance.co.nz"
3.the reply is all wrong

Actual Results:  
the whole page was full of chinese alphabet characters - the whole page!! - there was nothing else  - a whole page full of chinese alphabet characters.

Expected Results:  
with internet explorer the full website of "wheretodance.co.nz" should have been shown.

I have nothing else to add - except that, reporting bugs in Mozilla; as you have carefully designed, is virtually impossible for most people with typically average computor skills. This I think is deplorable!!

When your software screws up; as in this case; why make it virtually impossible for the poor recipient to advise you of your own cock up!!

kmiers@world-net.co.nz

Comment 1

16 years ago
Works for me, Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030416

page contains no DOCTYPE, renders in quirksmode
PageInfo shows encoding: UTF-16LE, 
but my standard setting in View/Character Coding   is   Western(ISO-8859-1)

Ken, could you specify this setting in View/Character Coding? Western(ISO-8859-1)

Im no specialist in Javascript, but this one definitely looks screwed up,
didn´t look if it is used or dead code in the page.

function openWindow1() { 
      menuWindow = open("photo.htm", "r_control",
"width=380,height=450,resizable=no,scrollbars=no"); // Windows가 Open되고 그곳에
Dipsplay될 HTML문서
   }

Comment 2

16 years ago
WFM, too with
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030416

I think there is somethin wrong with the prefereces of reporter's preferences.
Character Coding must be UTF-16LE, which will be used by my mozilla automatically.

INVALID?

Comment 3

16 years ago
Page seems to have a Korean comment in the Javascript:

// Windows? Open?? ??? Dipsplay? HTML??
(Reporter)

Comment 4

16 years ago
Created attachment 121139 [details]
select all copy from "wheretodance.co.nz" viewed in Mozilla 1.3

Hi 
I had forgotten my complain about this but on checking again the problem is
still there (mozilla 1.3 Site "wheretodance.co.nz")- site doesn't load - but
now instead of all chinese characters it as displayed in attachment - strange
English alphabet symbols and question marks.
I tried all the "View character coding" second level context menu and they only
slightly change the layout not the content. Ive never changed my character view
before it was on auto detect default Western European (windows).
Regards
Ken Miers
(Reporter)

Comment 5

16 years ago
Created attachment 121142 [details]
screen shot of wheretodance.co.nz on mozilla1.3

Hi
This is the start of the way my screen really looks, not as your programme
showed the previous attachment when i re viewed it from your log.
I couldn't put the full screen as the file was too big to attach and I don't
know how to list it on the web or attach it another way unless you tell me how.

regards
Ken
(Reporter)

Comment 6

16 years ago
Created attachment 121143 [details]
proper load of page in internet explorer

Page should view like this

Comment 7

16 years ago
Ken, YOUR problem would be solved, when View/CharacterCoding would have a fixed
setting (Western ISO-8859-1) instead of autodetect.
From what Autodetect sees on this page, assuming something other than Western is
ok. To fix Autodetect, there should be no korean comments in the code on this
website.
To fix this problem for other users of mozilla, the owner of the site should be
contacted. Please change the box 'Product' from 'Browser' to 'Tech Evangelism'
(Reporter)

Comment 8

16 years ago
Created attachment 121453 [details]
screen cap of mozilla 1.3 with view settings context bxs all open

Hi
Thanx yr reply but sorry you are not right, see attach, its already set to
that.
regards
Ken
(Assignee)

Comment 9

15 years ago
Worksforme with Mozilla 1.7 Alpha on winXP.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.