mousewheel sometimes scrolls till end of page




15 years ago
14 years ago


(Reporter: Varga Peter, Assigned: jag (Peter Annema))


Windows NT

Firefox Tracking Flags

(Not tracked)




15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030312

Sometimes, when rolling one with the mousewheel, it keeps scrolling till the end
of the page. It does it up and donw as well. While scrolling, if you roll one in
the other direction, it turns back but still keeps scrolling (to the other
direction). Does not depend on the page you are visiting, and it occures
frequently (usually at least once on any page).

Reproducible: Sometimes

Steps to Reproduce:
1. Just try scrolling.

Expected Results:  
scrolling the number of rows that are configured (3 rows in my case)

I use Windows NT 4.0 english, Logitech TrackMan marble with PS/2 plug.
This bug never happens in any other application, it's definitely Mozilla specific.
-> XP Toolkit and wfm with win2k build 20030415.. and MS Intelli Explorer
Assignee: asa → jaggernaut
Component: Browser-General → XP Toolkit/Widgets
QA Contact: asa → jrgm

Comment 2

15 years ago
This happens for me too.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

It *didn't* happen for me on Mozilla 1.4

I have a Logitech OEM wheelmouse, and I have the mouse gestures installed, I
don't know if this happened before I installed the genstures.

Comment 3

15 years ago
I uninstalled mozgest as per these instructions:
And this problem doesn't seem to happen any more.

Comment 4

15 years ago
-sigh- Spoke too soon, I guess, this still happens occasionally.

For me, it scrolls down about a page and a half before stopping, but rolling in
the other direction behaves as described here.

Comment 5

14 years ago
Some additionnal pointers: 
it seems to be linked with slowness:
I have both an AMD 300mhz and an AMD 2000+,
both with a logitech mouse (one's a Mouseman, the other is an MX300, but I tried
both on each).
the 300mhz has it in a ps2 plug, the 2000 has the mouse in USB.
I use Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
on the 300mhz, and Mozilla 1.6b release on the other.

I haven't seen this bug on the powerful machine, but I've seen it often on the
slower one, especially while loading pages (where response between mouse scroll
and actual scroll were delayed by the loading.)
Both have Mouseware 9.70.
As mentionned, when the bug shows up, the page goes all the way towards the last
wheel scrolling until it reaches an end, and the direction can be changed if
scrolling isn't over yet. Once the end is reached, though, it usually scrolls
fine, although chances are that it'll go all the way up/down again.
Note that grabbing the scrollbar won't stop it. It will effectively reposition
the scrolling position, but will then keep going in the direction it was going to.
Both have the scroll settings set to Scroll 1 line at a time.
Now, with this Phoenix release, I tried disabling the option "Use Autoscrolling"
in Advanced (smooth scrolling was disabled already), and this seems to have
fixed the bug. I haven't seen a wild-scroll for two days, while this used to
occur often.

Comment 6

14 years ago
*** Bug 252051 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
Duping to similar Bug 27667.  Reporter, if you feel this was done in error
please REOPEN.

*** This bug has been marked as a duplicate of 27667 ***
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.