Full path filenames are made links, but respond that drive is not a registered protocol when clicked.

VERIFIED DUPLICATE of bug 183111

Status

--
minor
VERIFIED DUPLICATE of bug 183111
16 years ago
14 years ago

People

(Reporter: mozilla_bugs_peep, Assigned: sspitzer)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

When receiving an message with a full path (drive, directory, and filename
(Well, drive is probably all that matters)) specified in the Microsoft format
(drive:\folder\filename.ext) Mozilla turns the text into a link.  Clicking the
link though, will pop up an error dialog saying "drive is not a registered
protocol".

This is a little strange to me because, being a Microsoft filename there are \
instead of /, and there is only one after the drive letter, as opposed to c:\\
or c:// (I'm thinking http://, ftp://, etc).  But I'm not familar with the
official standard, just what I've observed from using various programs.

Reproducible: Always

Steps to Reproduce:
1. Send mail to yourself and include "C:\Windows\Win.ini" in the message.
2. Get your mail.
3. Open the message
4. Click the link in the message.
Actual Results:  
An error message pops up saying "C is not a registered protocol."

Expected Results:  
The prefered result is Mozilla opening C:\Windows\Win.ini as it would if you
openned a browser window and typed "C:\Windows\Win.ini" into the address/URL
bar.  (Which on my machine displays the file as text in a browser window.)

An alternate result is that the link isn't highlighted.
there are 2-3 issues here :
a)
c:\blah\foo is wrong because it's no valid URL (no Protocoll and "\" is invalid
in an URL(. 
You get it highlighted because of a bug (bug 183111) 


b) you can't open a valid file:\\ link in Mozilla if the link is a document that
is not also loaded via file:// url (and the Mail URL is mailbox://).
You get a security Error in Tools\Web Development\Javascript Console
You can disable this csecurity-heck, see the Mozilla Release notes

c) with disabled security check you get another (kown) problem:
if you get a link to a document that should open with a helper app (Excel, Word) 
you can't edit this document because Mozilla will download the document to the
temp directory and after that launches the application with the document from
the temp folder.


*** This bug has been marked as a duplicate of 183111 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
verified dup and a.) is fixed tested again with trunk build 20030422 on winxp
macos and linux
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.