html dropdown does not show with new value when the value is changed if dropdown is in FEILDSET and LEGEND

RESOLVED DUPLICATE of bug 121127

Status

()

--
major
RESOLVED DUPLICATE of bug 121127
16 years ago
16 years ago

People

(Reporter: krishnakanth, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)
Build Identifier: using netscape 6.0, 6.2 7.0.2

If the dropdown in place in the FIELDSET and LEGEND and when new value is 
selected the dropdown does not repaint with the new value. For Example : In the 
page http://bugzilla.mozilla.org/query.cgi , go to Email and Numbering seciton, 
change the dropdown value and the dropdown would not refresh properly with new 
value. If dropdown is doubleclicked it works fine. This problem happens in 
netscape 6.0, 6.2, 7.02. The same thing works fine in IE 5.5 , 6.0

Reproducible: Always

Steps to Reproduce:
1. go to http://bugzilla.mozilla.org/query.cgi 
2. go to Email and Numbering seciton
3. change the dropdown values 

Actual Results:  
value would not refresh with the new value and the dropdown looks wiered

Expected Results:  
should work same as IE 5.5, 6.0

sample code

<HTML>
<HEAD>
<TITLE>Fieldset problem</TITLE>
</HEAD>
<BODY>
Please select an option below indicating the length of the report you are reques
ting.
<FORM action="..." method="post">
    <FIELDSET>
        <LEGEND align="top">Length of Report</LEGEND>
        Number of pages in the report:
        <SELECT NAME="Pages" SIZE="1">
        <OPTION VALUE="2 pages">2
        <OPTION VALUE="3 pages">3
        <OPTION VALUE="5 pages">5
        <OPTION VALUE="8 pages">8</SELECT>
        Number of words per page:
        <SELECT NAME="Words per Page" SIZE="1">
        <OPTION VALUE="150 words">150
        <OPTION VALUE="200 words">200
        <OPTION VALUE="250 words">250</SELECT>
    </FIELDSET>
</FORM>
</BODY>
</HTML>

Comment 1

16 years ago
Netscape 6.x is way too old. Even netscape 7.02 is old and you should post here
only bugs found using the latest Mozilla builds.

WFM using Mozilla 1.3, win98
This has been fixed in Mozilla since last August.

*** This bug has been marked as a duplicate of 121127 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.