Mail & Newsgroups / Composition options crashes mozilla since bugfix for 107877 was added.

VERIFIED FIXED

Status

SeaMonkey
Preferences
--
blocker
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: Frederic Bezies, Assigned: blizzard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030418
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030417

Since last wednesday, when bugfix for 107877 was added, everytime I want to go
to Mail & Newsgroups / Composition option, Mozilla quits without warning.

I am using a trunk based build Mozilla (lastest sources available) ; my build
option are --enable-crypto, --enable-xft, --disable-tests and --disable-debug.

I am sorry if this bug had been reported before.

Reproducible: Always

Steps to Reproduce:
1.Go to Preferences / Mail & Newsgroups
2.Click on composition line

Actual Results:  
Mozilla quits without warning.

Expected Results:  
Seeing options

Comment 1

15 years ago
Please enable debug and provide a stacktrace of your crash.

Perhaps a dup of bug 202439

(Reporter)

Comment 2

15 years ago
Ok. I will try to see with --enable-debug and a CVS updated source as soon as
possible.
(Reporter)

Comment 3

15 years ago
Created attachment 120962 [details]
crash log

Here is the log when launching debug-enabled based build.

I just go to Edit/Preferences / mail & Newsgroups and click on Compose.

Do you want gdb output ? How to make a stacktrace ? Sorry for this basic
question :-|
Crash in xft code
Assignee: ben → blizzard
(Reporter)

Comment 5

15 years ago
So, my thought was good. I thought xft was guilty here. I also noticed this bug
happens (quitting without warning) if in an account, html is on by default and
you want to compose a message.

Thanks for finding the guilty component.
(Assignee)

Comment 6

15 years ago
I just fixed this on the trunk before I saw this bug.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

15 years ago
Thanks for fixing it.
not a problem with today's build on linux.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 9

15 years ago
*** Bug 201848 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.