[RFE] No Distribution: local option?

VERIFIED WONTFIX

Status

--
enhancement
VERIFIED WONTFIX
16 years ago
10 years ago

People

(Reporter: bugzilla, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030415
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030415

Some of the newsgroups I'm subscribed to require that a post has Distribution:
local in the message headers. I've been going through the account settings and
newsgroup properties several times but I can't seem to find anything relevant.
Am I overlooking something? Thanks.

Reproducible: Always

Steps to Reproduce:
For those who don't know what the distribution header is, here is a short
description: <http://newsflash.concordia.ca/public/faqs/distribution.html>.

I couldn't seem to find any other bugs on this in bugzilla. Confirming as RFE.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: No Distribution: local option? → [RFE] No Distribution: local option?

Comment 2

16 years ago
The Distribution header may be added to the header part of the mailnews compose
window by adding the mail.compose.other.header backend pref. For example, to
make the Distribution header appear, you'd add the line

user_pref("mail.compose.other.header","Distribution")

to your user.js file. (If you're not familiar with how to set backend prefs, see
<http://www.mozilla.org/start/1.0/faq/general.html#1.5>)

Note that this only makes the header editable when composing...you still need to
add the value (in this case, "local") on a case-by-case basis. Having a default
header value applied to every message is bug #61520.

If this bug is simply for the ability to edit the Distribution header during
composition, it should be resolved invalid. If it's for the default header
value, it should be duped against bug 61520. Reporter, please clarify.
(Reporter)

Comment 3

16 years ago
Well yeah, like you said, now I get to select "Distribution:" and enter "local"
manually, which is already a big help, but what would be really convenient is an
option to set a default value for "Distribution:" for every newsgroup, with a
standard preference + dropdown rather than a manual config edit. So I guess this
is still a RFE as far as I'm concerned... But thanks, you've already been a
great help!

Comment 4

15 years ago
basiclly this is a wontfix.

you can add your own header via http://securemailer.ch/docs/mozilla_header.html
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Verified Won'tFix.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.