unable to edit existing images in editor due to JS error

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: Brade, Assigned: norrisboyd)

Tracking

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I am unable to edit an existing image in the editor due to the following JS
exception/error:  NS_ERROR_DOM_SECURITY_ERR

The call to CloneNode is failing for the image element.

To reproduce:
 * insert an image (I use http://warp/cha.gif but you can use a local or remote
image)
 * select the image by clicking it
 * click the image icon on the toolbar to view its properties

Notice that the location edit field for the image is blank (as are other fields/
settings).  Also notice the JS error on the console.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 1

19 years ago
*** Bug 20279 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Component: Security → Editor
QA Contact: junruh → sujay

Comment 2

19 years ago
Assigning QA to sujay.

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 3

19 years ago
reopening because I still do not see the location edit field populated
with the URL for the image..

As for the JS errors in console, On mac where is the console? Brade, maybe
you can verify this part...

Is this bug report two separate bugs? 1 bug for location edit field
and the other for JS errors, if it is norris let me know and I'll file
a separate bug for the location edit field issue...

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago

Comment 4

19 years ago
okay console messages are gone...so I'm closing this one out..
other issue will be filed as a separate bug if I can reproduce
it...selection problem.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
Kathy and I verified this one in her cube...the console messages are gone..

12/6 build.
You need to log in before you can comment on or make changes to this bug.