Javascript: Script text appears at top of page instead of intended text and form in proper location on page.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: raych, Unassigned)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312

If, having an account with eFax, one wish to change one's PIN, clicking on the
proper button for this, on the proper page of the above site, brigns up a page
which, instead of displaying the appropriate text and form at the proper
location in this page, displays the Javascript script at its top.

Ray

Reproducible: Always

Steps to Reproduce:
1. If you have an account (free or paid-for) with eFax, follow the site's
directions to change your PIN, clicking on a button to get the problem page. 
Otherwise, sign up for a free account and thereafter do the above.  [Hopefully
the sign-up will work for you; I had to have the eFax prexy's office do it.]
2.
3.

Actual Results:  
Javascript script at the top of the accessed page and no proper text and form in
the middle of the same page.

Expected Results:  
Javascript to produce the proper text and form for changing one's PIN for one's
eFax service.

Netscape 4.79 shows everything on that page correctly but reports, at the bottom
of its window, that there is a javascript error.  IE 6.0 also shows the page
correctly.  You may wish to just self-centeredly blame the site's Web designer,
but I say the this problem just once again illustrates that Moz is not as robust
as the other common browsers, in this imperfect world.

Comment 1

15 years ago
Raymond: can you please attach the page with the error to this bug for those who
have no such account?
If there is personal information on it, of course leave that part out (e.g. by
editing the file with a text editor if you have some knowledge of html; else you
could try with the visual editor Mozilla Composer, but make sure that the bug
still occurs after editing.
Maybe even already the shown script part is of help, but I doubt it.

> You may wish to just self-centeredly blame the site's Web designer

*sigh*
Do you have to add such comments to every bug report you file?
It seems to be a bit pert for 1) a technical bug database and 2) somebody who
has filed more than 40 bugs with more than half of them already resolved as
INVALID, WFM and DUPLICATE and the other half mostly not seen by anybody except
for you.

> I say the this problem just once again illustrates that Moz is not as 
> robust as the other common browsers, in this imperfect world.

When someone is not obeying the rules nobody may wonder when things do not work.
Let a bulldozer and a Cadillac collide. If only the Cadillac shows traces of
this collision, does that mean it's badly built?
As long as you don't collide (and you should have learned with your drivers
license that you shouldn't) the Cadillac is probably the vehicle of your choice.
(Reporter)

Comment 2

15 years ago
Checking this problem today, it doesn't exist.  I am now using Moz version 1.6b.
 This is an old bug report, entered when I used 1.3.  However, I suspect the
site fixed up its form script.  Since no one else corroborated a problem of this
nature here, I'll mark this 'FIXED'.  Is that all right?  Or for that label,
must I know that it was Moz that was fixed?

>> You may wish to just self-centeredly blame the site's Web designer

>*sigh*
>Do you have to add such comments to every bug report you file?
>It seems to be a bit pert for 1) a technical bug database 

For one that has opened itself to nontechnical users for a view of the outside
world's reaction to its browser's problems -- but one which repeatedly asserts
only its own narrow view of what the outside world should want in what it claims
is a general-purpose browser it is designing?  Better pert than dirt.

>and 2) somebody who
>has filed more than 40 bugs with more than half of them already resolved as
>INVALID, WFM 

Hey, I can't fix the judges.

>and DUPLICATE 

Well, with some of your terminology, I can't find reasonably simples ways of
finding existing bug reports appropriate for my bugs.

>and the other half mostly not seen by anybody except
>for you.

. . .because because essentially all of them do not use the browser I am using,
namely Win98SE.

>> I say the this problem just once again illustrates that Moz is not as 
>> robust as the other common browsers, in this imperfect world.

>When someone is not obeying the rules nobody may wonder when things do not >work.
>Let a bulldozer and a Cadillac collide. If only the Cadillac shows traces of
>this collision, does that mean it's badly built?
>As long as you don't collide (and you should have learned with your drivers
>license that you shouldn't) the Cadillac is probably the vehicle of your >>choice.

Oh?  If IE, Netscape 4.x and Opera hit a bulldozer(?) and don't suffer damage --
and even take great videos of the action; but when Moz hits the same earth
mover, at the very same angle and speed, and Moz splatters all over the street.
. .gimme one o' them ugly non-Gecko Hummers, thank you.

Ray (Not an expert in automotive metaphores)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 3

15 years ago
> I'll mark this 'FIXED'.  Is that all right?  Or for that label,
> must I know that it was Moz that was fixed?

Correct: if it was a Mozilla bug and it is known which patch solved the problem,
then FIXED is the resolution.
If the Mozilla bug somehow disappeared in the curse of time, it's WORKSFORME, if
it was not a Mozilla bug, it's INVALID.

In this case we cannot find out what it was, so I choose WFM.
Reopening for resolving.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 4

15 years ago
> > and 2) somebody who
> > has filed more than 40 bugs with more than half of them already resolved as
> > INVALID, WFM 

> Hey, I can't fix the judges.

Tell me where the resolution was wrong and I'll reopen. IF it was really wrong
by Mozilla.org's terms. If it was correct, please respect point 2. 2.) of the
bugzilla etiquette - you know the URL by now.

> > and the other half mostly not seen by anybody except
> > for you.
> . . .because because essentially all of them do not use the browser I 
> am using, namely Win98SE.

This is plain wrong. Yesterday on bugday I got several Win98 users to test your
bugs. At least one explicitly stated that he was using the same configuration
you are using.
And *if* there are really that many people still using Win98(SE) and *if* they
all (or most of them) see the bugs you see - you claim both - then where are
they? Why does none of them comment on these bugs?

> [automotive metaphore]

I don't use browsers on streets.
So Mozilla does not need to survive a crash with a bulldozer. However, Mozilla
has to do its job as browser and using it several hours a day I can truly say it
does it's job very well.

Subtract your strange plugin errors from what Mozilla does "wrong" in your
Opinion and it already will be a much better browser. And then we can talk about
incorrectly built web sites...


Ah, well:
resolving as WFM per reporter's comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.