HTML Table heights don't support percentages as arguments

RESOLVED DUPLICATE of bug 88035

Status

()

Core
Layout: Tables
--
enhancement
RESOLVED DUPLICATE of bug 88035
15 years ago
15 years ago

People

(Reporter: David, Unassigned)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312

My web site was originally designed in IE 5.5, before I got Mozilla...  Anyway,
the ONLY problem I'm having (I previously reported a CSS bug which turned out to
be flawed code on my behalf due to a badly written book...) is that my code for
the HTML table is supposed to make the main table occupy the ENTIRE height of
the page.  Table height properties in Mozilla only accept pixel values, not
percentages.  The table width properties work fine with percentages as arguments.

Reproducible: Always

Steps to Reproduce:
Simply visit the website.  The best thing to do would be compare how the page
looks in IE and Mozilla.
Actual Results:  
see Details

Expected Results:  
see Details

Comment 1

15 years ago
Tested on: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030418

Mozilla DOES support table height percents, but height="100%" is messed up when
you have a center tag around the table.  Bug 88035 covers the center tag
weirdness.  David, to fix your page simply remove the center tags that are
around the table.  Centering a table that fills the entire window doesn't really
make much sense.

As well, you have a 2 height attributes in the table tag (line 10).  Although
these appear to have no effect, you should probably remove the one you don't
want so you don't have any problems in the future.

This bug should be a dup of bug 88035.

P.S. completely unrelated to this bug: your stylesheet declaration has a space
in the type attribute (right before text/css) - type =" text/css"

Comment 2

15 years ago
Created attachment 121063 [details]
testcase

This testcase shows the bug.  If you remove the center tags, the table takes up
100% of the window like its supposed to do.

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 88035 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.