{inc}incorrect placement/overlap on very tall div

RESOLVED WORKSFORME

Status

()

Core
Layout: R & A Pos
P4
normal
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Brian Sperlongano, Unassigned)

Tracking

({testcase})

Trunk
Future
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030419
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030419

I have created a test case (http://www.eviljournalist.com/t3.html).  This
problem only seems to occur on remote pages - it seems to render fine when
loaded from a local file.  When you have a really tall div overlapping the
margin of another div, it will resize itself and overlap the main div.  For a
real-world example page in which this occurs, see http://www.eviljournalist.com/

When the Mozilla window is resized, all page elements re-render themselves
correctly.  This problem only occurs on first load.

Reproducible: Always

Steps to Reproduce:
See test case at http://www.eviljournalist.com/t3.html
Actual Results:  
div overlap occurs

Expected Results:  
div should stay wholly to the right of the main div. (see test case)

Browser-only install of Mozilla 2003041904
Seeing this on Linux too; looks like the initial reflow of the abs pos div ends
up placing it incorrectly....
Assignee: block-and-inline → position
Status: UNCONFIRMED → NEW
Component: Layout: Block & Inline → Layout: R & A Pos
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: incorrect placement/overlap on very tall div → {inc}incorrect placement/overlap on very tall div

Comment 2

15 years ago
testcase provided in url.
Keywords: testcase
Priority: -- → P4

Updated

15 years ago
Target Milestone: --- → Future
(Reporter)

Comment 3

13 years ago
This appears to be fixed in my nightly build (01/12/05).  I suspect it was the
same bug as the Slashdot problem.  Can anyone else verify that this is indeed fixed?

Comment 4

13 years ago
wfm, SeaMonkey 2005-07-28-01 trunk Linux (I can reproduce it in Mozilla 1.7.8)

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.