rtsp:// (real media streaming servers) unsupported protocol

RESOLVED WONTFIX

Status

()

enhancement
RESOLVED WONTFIX
16 years ago
3 years ago

People

(Reporter: playboy, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030401
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030401

It seems that any rtsp:// real media streaming server causes mozilla to give an
unsupported protocol error when trying to open links with the rtsp:// prefix,
even with the latest real player 8 installed as a plugin.

Reproducible: Always

Steps to Reproduce:
1. Go to any website that offers streaming media in real
2. If the link is on an rtsp:// server click the link.
3. Mozilla reports that rtsp:// is an unsupported protocol.

Actual Results:  
The aforementioned error window popped up.

Expected Results:  
It should have opened up the url in my realplayer app.  The plugin is installed.

Comment 1

16 years ago
dupe of bug 68406, via bug 82776

*** This bug has been marked as a duplicate of 68406 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Does this work on other platforms? This is actually more linux-only bug 33282
Component: Browser-General → Networking
QA Contact: asa → benc
Summary: Browser does not open urls with rtsp:// protocol for real media streaming servers, mozilla reports and unsupported protocol → rtsp:// protocol for real media streaming servers, mozilla reports and unsupported protocol

Comment 3

16 years ago
REOPEN: Bug 33282 has three recent duplicates mentioning the same problem, so
I'm creating this as a tracking bug.
Status: RESOLVED → UNCONFIRMED
Depends on: 33282
Resolution: DUPLICATE → ---

Comment 4

16 years ago
-> NEW, defaults.

I've tried Mac and this works, and I'm going to assume it works for windows,
meaning this is indeed Linux-only, and a valid dependency of bug 33282.
Assignee: asa → darin
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

16 years ago
*** Bug 217850 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
*** Bug 217170 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
*** Bug 82776 has been marked as a duplicate of this bug. ***
*** Bug 227062 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
Adding user_pref("network.protocol-handler.app.rtsp",
"/usr/local/bin/gmplayer"); to prefs.js gets me far enough that MPlayer loads up
and complains that I didn't compile it with rtsp support.  

I think this only works in 1.6b, as that was when the dependent bug was fixed. 
If that's all you're looking for (external app support) I'd say "works for me".
 Excepting, of course, the caveat that passing username/password/port options
may not be implemented or work.

<a href="http://linux.sgms-centre.com/howto/mozilla.php">This article</a> gives
a good overview of using external protocol handlers with Moz.

Comment 10

15 years ago
To confirm Ben Smith's suggestion, I added the pref, setting the value to
/usr/X11R6/bin/realplay, and it works just fine. (I think mplayer would work
too, although it doesn't actually stream video, so it's not as nice to use as
Real's Linux port.) 

Since Real now has a fairly-official (although not supported) version of
Realplayer, which installs by default to that directory, would it be rash to set
this preference to this directory for Linux in future versions of Mozilla?

At a minimum, some documentation on this would be very helpful!

Updated

15 years ago
Blocks: 37637

Comment 11

15 years ago
yes, <a href="http://linux.sgms-centre.com/howto/mozilla.php">

works with 
" about:config (right-click on any item) --> new --> boolean -->  
network.protocol-handler.app.rtsp --> /usr/X11R6/bin/realplay "

as reported.

Sometimes the java apps don't work and the rtsp links can be found in "View page
Source" my right-clikkin a bum pop-up.
(Noramlly my Mozplugger works OK).

Like this one :

rtsp://a988.v101995.c10199.e.vr.akamaistream.net/ondemand/7/988/10199/3f97c7e6/ftvigrp.download.akamai.com/10199/horsgv/regions/siege/infos/f3/1214/1214_20040426.rm
*** Bug 242022 has been marked as a duplicate of this bug. ***
(In reply to comment #11)
> yes, <a href="http://linux.sgms-centre.com/howto/mozilla.php">
> 
> works with 
> " about:config (right-click on any item) --> new --> boolean -->  
> network.protocol-handler.app.rtsp --> /usr/X11R6/bin/realplay "
> 
> as reported.
> 
> Sometimes the java apps don't work and the rtsp links can be found in "View page
> Source" my right-clikkin a bum pop-up.
> (Noramlly my Mozplugger works OK).
> 
> Like this one :
> 
>
rtsp://a988.v101995.c10199.e.vr.akamaistream.net/ondemand/7/988/10199/3f97c7e6/ftvigrp.download.akamai.com/10199/horsgv/regions/siege/infos/f3/1214/1214_20040426.rm


1) adding a string so users searches on Google will get to this page :)
rtsp is not a registered protocol

2) Of course, you dont want to add a boolean, but rather a string :
Quoting you:

works with 
" about:config (right-click on any item) --> new --> string -->  
network.protocol-handler.app.rtsp --> /usr/X11R6/bin/realplay "

Updated

15 years ago
Summary: rtsp:// protocol for real media streaming servers, mozilla reports and unsupported protocol → rtsp:// (real media streaming servers) unsupported protocol

Comment 14

14 years ago
(In reply to comment #4)
> -> NEW, defaults.
> 
> I've tried Mac and this works, and I'm going to assume it works for windows,
> meaning this is indeed Linux-only, and a valid dependency of bug 33282.


Hi,

This is not working in Windows XP. Could you please suggest me the solution. In
Windows xp , I have installed mozilla firefox 1.0.6. When I open any rtsp
protocol i am getting Not registred protocol error. Could you please tell me how
to resolve this issue.

Please reply to harishbabu_gk@yahoo.com


Thanks
Regards
Harish

Comment 15

14 years ago
Using Kubuntu I added to about:config

network.protocol-handler.app.rtsp string /usr/bin/X11/realplay
network.protocol-handler.external.rtsp user set boolean true

It opens now Realplayer and I have sound, but no picture. Or has this more to do with Realplayer itself or the rtsp:link? 
that must be realplayer-specific...

Comment 17

13 years ago
Although this is listed as a Linux bug, I believe it is not restricted to that platform.  I am running the Firefox 1.6a1 build from 20060118 on Windows XP and get the message:

Firefox doesn't know how to open this address, because the protocol (rtsp) isn't associated with any program.

I added the following two lines to prefs.js:

user_pref("network.protocol-handler.app.rtsp", "C:\\Program Files\\Real\\RealPlayer\\realplay.exe");
user_pref("network.protocol-handler.external.rtsp", true);

but that made no difference.  I also tried using Quentessential Player as the app with the same result.  My test site for this is the http://www.c-span.org/ video archives.  All links to video clips fail.  Either the OS for this bug should be changed or a new bug should be entered for Windows if they are not one bug.

Comment 18

13 years ago
(In reply to comment #16)
> that must be realplayer-specific...
> 

Yes, it is. To solve the problem (sound but no picture for rtps:) in Realplayer:

#  In RealPlayer, under Tools, click Preferences
# In the Preferences window, click the Transport tab.
# Click Use Specified Transport.
# Click Configure RTSP... The Transport Settings window appears:
# UnClick Attmept Multicast.
# UnClick Attmept UDP.
# UnClick Attmept TCP.
# Click Attmept HTTP.
# Click OK in the Transport Settings window.
# Click OK button in the Preferences window to save your changes

Thanks to Mitch for this solution!

Comment 19

13 years ago
Is there a way to make the rtsp or mms protocol forward to a plugin. I would really like to be able to have mplayerplug-in handle an rtsp or mms stream.

Updated

13 years ago
Assignee: darin → nobody
QA Contact: benc → networking

Comment 20

13 years ago
(In reply to comment #19)
> Is there a way to make the rtsp or mms protocol forward to a plugin. I would
> really like to be able to have mplayerplug-in handle an rtsp or mms stream.
> 


I was having trouble with the cspan video feed. I uninstalled RealPlayer. I was using RealPlayer7 because 10 is overbloated. I installed RealAlternative 1.49, which installed Media Player Classic and it asked if I wanted to add connections to firefox. Just what I wanted!!!!

Comment 21

13 years ago
The solution lays within Real Player preferences. 

Open Real Player/Tools/Preferences/Content/Media Types/Manually configure media types for RealPlayer/Select, scroll down to Real-Time Streaming Protocol and mark it.

This worked in Real Player 10.5
How would this be affected by Bug 506834? If native RTSP support was added to Gecko for audio/video, would realplayer be able to override it?
This bug still remain and needs more attention.

Related bug on GNU/linux for handle protocols:
https://bugzilla.mozilla.org/show_bug.cgi?id=312953
Status: NEW → RESOLVED
Last Resolved: 16 years ago3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.