If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cannot see which accounts received new messages when using filters to move mail between accounts

NEW
Unassigned

Status

SeaMonkey
MailNews: Message Display
15 years ago
8 years ago

People

(Reporter: Rotaluclac, Unassigned)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030312

I have seven mail accounts.  Six of them are forwarded email addresses, so I
physically receive all mail through a single default account.  I use filters to
distribute incoming mail over the seven accounts.
When new mail arrives, the "new mail" indicator (green arrow) only shows up for
the default account.  I want it to show up for those accounts where the filters
put the messages.

Reproducible: Always

Steps to Reproduce:
1. Create several accounts.
2. Create filters to move mail from the Inbox of the default account to
   any mailbox of any of the other accounts.
3. Retrieve new mail that is moved by the filters to other accounts.

Actual Results:  
The default account gets the "new messages" indicator.  The other accounts get
no such indicator.

Expected Results:  
Only those accounts where the new messages actually landed should get the "new
messages" indicator.
(Reporter)

Comment 1

15 years ago
This bug may have to do with bug 195827.  Yet, it looks different enough to me
to create a new bug.

Comment 2

15 years ago
I think you were right about the dupe.  It's very similar, also, to Bug 186573, 
which is getting scads of dupes.

*** This bug has been marked as a duplicate of 195827 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
Not a dupe!
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

15 years ago
This bug includes the behavior of bug 116181 (green arrow should not be applied 
to an account where all the new mail has been filtered to other accounts) but 
also specifically request that the green arrow *is* applied to accounts that 
have received new mail due to filtering from another account -- currently, only 
the folder receiving the new filtered mail gets the green arrow.

See also bug 107206.
Status: UNCONFIRMED → NEW
Depends on: 116181
Ever confirmed: true

Comment 5

13 years ago
I just came across this bug.  Since, there hasn't been any activity in over a
year, I just want to confirm that comment #4 is still accurate for 1.7.3 and the
nightly trunk build 20040922.  This was on Linux and WinNT.
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
Karsten, Larry, Rotaluclac - do you see this on Seamonkey?

In thunderbird in folder pane I get an indicator on the folder, but not on the account. And nothing in the windows notification area.

bug 224823 a dup?
This is still an issue with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2pre) Gecko/20070110 SeaMonkey/1.1

Comment 8

11 years ago
No, 224823 is not a dupe.  That bug is about the bolding/message count on a folder, running filters after-the-fact; this bug is about the New flag on an account with filters on arriving mail.

224823 WFM, by the way.
Assignee: mail → nobody
QA Contact: esther → message-display
You need to log in before you can comment on or make changes to this bug.