My bookmarks were wiped out.

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
--
critical
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Rhi Bigner, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

I loaded Mozilla and found that all of my bookmarks were gone. In the folder
that Mozilla uses to store it's data, c:\documents and settings\(my
name)\mozilla\profiles\default\qj9vqd8y.slt\, bookmarks.html contains just this

<!DOCTYPE NETSCAPE-Bookmark-file-1>
<!-- This is an automatically generated file.
It will be read and overwritten.
Do Not Edit! -->
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=UTF-8">
<TITLE>Bookmarks</TITLE>
<H1>Bookmarks</H1>

<DL><p>
</DL><p>

rather than the several hundred bookmarks that should be there.

Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.
Do you had a system crash before ?
(Reporter)

Comment 2

15 years ago
It seems to be a problem with ATI's latest video drivers (Catalyst 3.2). My
bookmarks were wiped again (fortunately I had a recent backup this time). From
perusing the event viewer, it seems that when the ATI Smart service is started,
I get a BSOD...

PAGE_FAULT_IN_NONPAGED_AREA
stop 0x00000050
ati3d2ag.dll

The first time after this error, my bookmark file was totally wiped out. The
second time different portions of it were wiped out.

I really don't have the programming experience to tackle something like the
Mozilla source so I don't know if the code for saving and loading the bookmarks
could be made more fault tolerant.

However, I didn't have this problem with any earlier drivers (3.1, 3.0a, 3.0,
etc) so I'll just roll back.

Comment 3

15 years ago
Reporter: What graphic card do you have? It seems the 3.1/3.2 drivers have many
problems with the Radeon 8500 (search through Google Groups with the name of
that DLL).
(Reporter)

Comment 4

15 years ago
Ooops...the ATI Smart Service is started at boot and Windows logs the error
after reboot.

For at least the last couple of times, it seems to happen when I close Mozilla
by clicking the top right corner of the window. I've tried reproducing it to no
avail.

I've gone back to 3.1 to see if that helps.

I have a Radeon 8500LE.
(Reporter)

Comment 5

15 years ago
Same problem w/ the 3.1 drivers. I'm going to try the 3.0 set and turn off write
caching for my hard drive. Hopefully I'll at least stop losing my bookmark file.

Comment 6

15 years ago
Is this still an issue with 3.4 drivers?

Comment 7

15 years ago
Is this still an issue with 3.4 drivers?
(Reporter)

Comment 8

15 years ago
I no longer have the problem w/ Mozilla 1.6 and Catalyst 4.1.

Updated

15 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.