drag and drop of text in compose window not working (both plaintext and html)

RESOLVED WORKSFORME

Status

MailNews Core
Composition
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Calum Mackay, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030421
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030421

drag and drop of text in a plaintext compose window is not longer working. It
used to move the text, now it seems to do nothing. This does not seems to affect
other mozilla text windows. e.g typing in *this* details box, drag and drop is
working fine.

This broke (for me) in sometime between 20030412 and 20030415. 

For html compose it's even worse, with text being moved to the wrong location
nowhere near the cursor.

Reproducible: Always

Steps to Reproduce:
1.drag and drop some text within the plaintext compose window.
2.
3.

Actual Results:  
nothing

Expected Results:  
the text should move

Comment 1

16 years ago
Never seen this "feature" before, but it appears to work fine for me in the 
compose window. Select a work, words, move out of the selection move back in 
and keep button-1 (on the mouse) pressed and the test can be dragged and
dropped as expected.

Comment 2

16 years ago
Sorry, the paste (drop) works fine in the subject line, but not
in the body of the composer. Looks like the composition body window
is no longer recieving drop events.
(Reporter)

Comment 3

16 years ago
Interesting that the drop into the subject line (or any header line) works, but
is treated as a copy/paste, rather than a cut/paste.

wouldn't one always expect a drag to result in a cut, by default?

anyway, that's a separate issue :)

Comment 4

15 years ago
In general drag and drop in the compose window works for me using Mozilla/5.0
(Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624, but see bug 212499.

As comment 3 is indeed a separate issue, and seems to be one in Windows, not
just Linux, but does not seem to have been filed as such, I have filed it as bug
212500.

Comment 5

15 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b; MultiZilla
v1.5.0.1) Gecko/20030827

WFM for plain text composition at least

Comment 6

15 years ago
Text drag is working for me, 1.5 Final, Windows2000, with plain and HTML 
composition.

Calum Mackay, is this bug still an issue for you?  If not, please mark this bug 
as:   Resolved|WorksForMe
(Reporter)

Comment 7

15 years ago
Apologies, I've somehow missed the updates to this bug.

It does indeed appear to be fixed now.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.