Save Link Target as results in "The Link Could Not be Saved...."

RESOLVED FIXED

Status

Core Graveyard
File Handling
RESOLVED FIXED
15 years ago
2 years ago

People

(Reporter: Richard Weingartner, Assigned: Bill Law)

Tracking

({top100})

Trunk
x86
Windows XP
top100

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030401

When in the files section of any Yahoo! group and trying to use the Save Link
Target As or shift-clicking the file to save it to the hard drive, the "The link
could not be saved.  The web page might have been removed or had its named
changed."  This only started today on Yahoo! groups,  I tried it someplace else
and the shift-click/save link target as worked.  So I think it's an
imcompatability between something Yahoo! changed and mozilla.

Reproducible: Always

Steps to Reproduce:
1. Go to any Yahoo group file secion.
2. Right click and choose save file as or shift-click on filename.

Actual Results:  
I receive the error message: "The link could not be saved.  The web page might
have been removed or had its named changed." 

Expected Results:  
Opened the Save As dialog box.

Comment 1

15 years ago
Save As:
Yahoo responds to the HEAD request with a 403 Forbidden Error
Click file:
Yahoo responds to the GET request with 200 OK  and the content.

Bug 160454 is the tracking bug for HEAD request used in Save as.

Comment 2

15 years ago
-> file handling
Assignee: darin → law
Component: Networking: File → File Handling
QA Contact: benc → cpetersen0953

Comment 3

15 years ago
This same problem came up for me in Yahoo Briefcase.  I'd encountered it quite a
while ago (in 1.2.1, I have 1.3 now), then had it disappear.  Now it's back.  I
say that the reproducibility is intermittent.

The workaround for this is using IE.

Comment 4

15 years ago
This bug is now reproducible at http://www.mozilla.org/ in 1.4 (Build 20030624)

Comment 5

15 years ago
The first time I hit the nightly ftp tree (shift + right button) I get this error
too. The download starts on the second (+) try. I haven't traced the session
(yet). Repeatable by changing dirs and the only the first ftp try fails.
I'm win2k - anyone else try the trunk linux release yet?

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/2003071108

Comment 6

14 years ago
I can confirm this with a recent 1.7 trunk build on winxp.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: top100

Comment 7

14 years ago
*** Bug 233376 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
*** Bug 211468 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
Same on Amazon.com, do a search for any thing and then try and save it, perhaps
its with dynamic pages?

Comment 10

14 years ago
Seems like this may be a dupe of Bug 160448; although that bug doesn't mention
it anywhere, I gather that the reporter is talking about right clicking and
choosing "Save Link As..." also since he contrasts his experience with
left-clicking and having no problem.  Also, both discuss issues with HEAD method
and save-as, and both depend on Bug 160454.

Comment 11

14 years ago
*** Bug 252208 has been marked as a duplicate of this bug. ***
I've tested "Save Link Target As ..." with some file in:
http://groups.yahoo.com/group/svg-developers/files/

I see the bug with a Seamonkey build of 2004-10-07, but I don't see the bug
anymore with a Seamonkey build of 2004-10-10.
It seems to be fixed by the fix for bug 160454. Marking FIXED.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.