Random URLs opening up for no real reason

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: David Buckley, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

Bit of a strange one, this, but since I've now experienced it twice (Once one my
parent's Win2K machine, once on this Linux box; both on Phoenix 0.5), I figure
it's probably genuine.

As best I can figure out, the bug is possibly in the middle click code; this
time, when it happened, I clicked the "Watch" URL at
http://artists.mp3s.com/info/131/linkin_park.html with the middle button, got a
new window and had the current page redirect itself to
http://www.hinduonnet.com/thehindu/2002/12/06/16hdline.htm (And I'm /damn sure/
I've never ben there before in my life).

First time I got it was on the Win2K machine, forget what I was reading, but I
think it was also a middle click that caused it; I ended up on the Linux
Wireless HOWTO, which again, I'm pretty damn sure I've not visited before.


Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. Load http://artists.mp3s.com/info/131/linkin_park.html
2. Middle click "Watch" on the top layer of menu.

Actual Results:  
New window popped up, current page redirected to
http://www.hinduonnet.com/thehindu/2002/12/06/16hdline.htm .

Expected Results:  
Probably: New window pops up, current page refreshed.

I suspect this is an arch and OS independent bug.
(Reporter)

Comment 1

15 years ago
OK, been playing around with the Phoenix that I left open. I can't reproduce the
bug by visiting the site, but the window, which I left open, can still reproduce
it. It picked a /different/ random URL this time, see:

http://cypher.dnsalias.org/~bucko/Phoenix1.jpg (Mouse hovering over menu, pre click)

http://cypher.dnsalias.org/~bucko/Phoenix2.jpg (Browser state, after I middle
clicked, and closed the resulting popup)

Now I look at it (just tried it again), I realise it's probably some sort of
bizarre function of the "middle click uses URL in clipboard as target" feature
(which I really don't like, but nonetheless...), probably getting confused with
some Javascript. This is all very well, except I'm /DAMN SURE/ these URLs have
never been in my clipboard... so where /did/ they come from?
>20021207
Sorry but this is to old to report bugs.
Please reopen if you see this with a more recent build.

This could be part of the google redirect that they use in Phoenix (but not in
mozilla)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.