checksetup.pl is showing 'cache failed to write'

RESOLVED WORKSFORME

Status

()

--
blocker
RESOLVED WORKSFORME
16 years ago
6 years ago

People

(Reporter: sven.fischer, Assigned: zach)

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

./checksetup.pl

Checking perl modules ...
Checking for       AppConfig (v1.52)   ok: found v1.52
Checking for       CGI::Carp (any)     ok: found v1.14
Checking for    Data::Dumper (any)     ok: found v2.101
Checking for     Date::Parse (any)     ok: found v2.24
Checking for             DBI (v1.13)   ok: found v1.14
Checking for      DBD::mysql (v1.2209) ok: found v2.0416
Checking for      File::Spec (v0.82)   ok: found v0.82
Checking for        Template (v2.07)   ok: found v2.08
Checking for      Text::Wrap (v2001.0131) ok: found v2001.0929
Checking for       CGI::Carp (any)     ok: found v1.14

The following Perl modules are optional:
Checking for              GD (v1.19)   ok: found v1.19
Checking for     Chart::Base (v0.99)   ok: found v0.99
Checking for     XML::Parser (any)      not found

If you want to use the bug import/export feature to move bugs to or from
other bugzilla installations, you will need to install the XML::Parser module by
running (as root)

   perl -MCPAN -e'install "XML::Parser"'

Checking user setup ...
Removing existing compiled templates ...
Precompiling templates ...
Content-type: text/html

<H1>Software error:</H1>
<CODE>Could not compile index.html.tmpl:file error - cache failed to write
index.html.tmpl: Can't use string (&quot;DIR&quot;) as a HASH ref while
&quot;strict refs&quot; in use at
/usr/lib/perl5/site_perl/5.6.0/i586-linux/Template/Document.pm line 171.

</CODE>
<P>
For help, please send mail to this site's webmaster, giving this error message
and the time and date of the error.

[Tue Apr 22 15:01:29 2003] checksetup.pl: Could not compile index.html.tmpl:file
error - cache failed to write index.html.tmpl: Can't use string ("DIR") as a
HASH ref while "strict refs" in use at
/usr/lib/perl5/site_perl/5.6.0/i586-linux/Template/Document.pm line 171.
[Tue Apr 22 15:01:29 2003] checksetup.pl:


Reproducible: Always

Steps to Reproduce:
1.installed missing perl packages
2.called checksetup.pl
3.added infos for mysql access to localconfig file
4.rerunning checksetup.pl
5.getting that errormessage



Expected Results:  
checksetup.pl should run and terminate properly

There was before a problem with installing Template-Toolkit-2.08, where I
commented one line out which was including something in the file, what (maybe)
wasn't used in that file.I found that hint in the web.

This problem here I also found mentioned in the web once, but without any solution.

I'm using SuSE distribution with Linux 2.4.4, and perl 5.6.0
(Assignee)

Comment 1

16 years ago
I'm pretty sure this isn't a bugzilla problem, since the error is coming from
the Template Toolkit and you had to comment out a line in the TT installation. I
recomend that you email the Template Toolkit mailing list with details of the
error that you had during installation. ->WORKSFORME
(Assignee)

Comment 2

16 years ago
marking worksforme, reporter please reopen if you are still having this issue
with a fully functioning installation of the template toolkit
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.