Closed Bug 202904 Opened 20 years ago Closed 19 years ago

IconLoad does not register itself as a pref observer

Categories

(Core :: Layout: Images, Video, and HTML Frames, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 180620

People

(Reporter: bzbarsky, Assigned: jdunn)

References

Details

The IconLoad object caches some prefs and does not register itself as a pref
observer.  This means that its concept of what's going on can get out of sync
with the current content policy.  When combined with bug 201885 this means that
we could fail to show alt text for blocked images if image loading is turned off
without restarting.
Depends on: 201885
*** Bug 200023 has been marked as a duplicate of this bug. ***
*** Bug 205979 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 180620 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.