Untranslated strings during install when using wizard

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
16 years ago
9 years ago

People

(Reporter: mkaply, Assigned: ssu0262)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Currently, per this code:

http://lxr.mozilla.org/seamonkey/source/xpinstall/src/nsInstall.cpp#2722

Certain strings during the install:

http://lxr.mozilla.org/seamonkey/source/xpinstall/src/nsInstallResources.cpp#36

are always in English.

We need to provide a mechanism to translate these strings. We should have the
ability to translate the entire project.

My only thought is to use some syntax like %creatingfolder% and then do
replacement on that string with something queried from INSTALL.INI or CONFIG.INI

Comment 1

15 years ago
Only string i see in English is "Installing <package>", above the lower of the
two progressbars.
That would be the string I am talking about.
Product: Browser → Seamonkey

Updated

13 years ago
QA Contact: bugzilla → general

Comment 3

10 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 4

9 years ago
old XPFE installer is dead.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.