netscape.com - Get Java from http://java.sun.com/getjava instead of plugins.netscape.com

RESOLVED DUPLICATE of bug 355299

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 355299
14 years ago
10 years ago

People

(Reporter: Jack Lu, Unassigned)

Tracking

({topembed-})

Trunk
topembed-
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [plugin])

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705)
Build Identifier: 20030422

Currently if the user does not have Java installed on his/her system and he/she 
visits an applet page (using APPLET tag), he/she will be redirected to 
http://plugins.netscape.com to download Java. However, for APPLET tag user, we 
would like the user to get the latest JRE. Since the conflicts of release 
schedule between Java Runtime Enviroment (JRE) and Netscape/Mozilla, Netscape 
usually hosts the old version of JRE which usually prevents the user from using 
the latest Java technology. 

This bug basically addresses the problem by redirecting the user to 
http://java.sun.com/getjava/manual page. Currently that page hosts JRE 1.4.1_02 
for Windows and Unix platform. For all the platforms, it is in EXE/tar/ZIP 
format currently and we are going to make xpi file for Windows platform in 
1.4.2 release which is going to be available soon. But for Linux platform, we 
are continuing using TAR format due to GCC compiler issue.
 

Reproducible: Always

Steps to Reproduce:
1. Remove Java from your system
2. Visit http://java.sun.com/applets and click "Bubbles"
3. 
Actual Results:  
It prompts you to download JRE from plugins.netscape.com


Expected Results:  
We would like to have the download page to be 
http://java.sun.com/getjava/manual.html

Both Netscape and Sun agrees my proposal above
(Reporter)

Comment 1

14 years ago
Created attachment 121325 [details] [diff] [review]
Patch for fixing the issue

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

14 years ago
Mike,

By the way, in order to make the current browser to work, we need to redirect 
the current JRE download page to http://java.sun.com/getjava/manual.html as 
well.

Comment 3

14 years ago
peterl, can you r= this patch?  I'd like to seriously get this in for any
product timeframe that counts.
alternatively, if a patch isn't necessary, perhaps I can get the
http://plugins.netscape.com page to redirect to the page that Xiaobin is proposing.

Comment 4

14 years ago
Nominating nsbeta1 and topembed.
Keywords: nsbeta1, topembed

Comment 5

14 years ago
Comment on attachment 121325 [details] [diff] [review]
Patch for fixing the issue

r=peterl
Attachment #121325 - Flags: review+

Comment 6

14 years ago
peterl et al.,

On balance, it seems that although Xiaobin has proposed a valid patch, perhaps
one good way to solve this problem is to make sure that the old page (on
*.netscape.com) issues a redirect to the new page (on *sun.com).  So let me work
towards making this happen, and if I totally fail (for whatever reason) we can
think of a hardcoded client side solution.
Reassigning to me.
Assignee: peterlubczynski → aruner
Component: Plug-ins → Plugins
Product: Browser → Tech Evangelism
Target Milestone: --- → May
Version: Trunk → unspecified

Comment 7

14 years ago
yeah, I agree: changing the server to redirect is better so we also update
clients in the field.

Comment 8

14 years ago
Discussed in edt and offline.  Plussing.
Keywords: topembed → topembed+

Comment 9

14 years ago
This is not an embedding issue. Minus'ing for embedding; NSBeta1 KW still holds.
Keywords: topembed+ → topembed-

Comment 10

14 years ago
The fix will be as follows:

1. The PFS (Plugin Finder Service) entry for Java is going to get redirected so
that instead of having Netscape/Mozilla browsers obtain Java from the existing
XPInstall bundle(s), they will obtain it from
http://java.sun.com/getjava/manual.html instead.

2. Netscape/Mozilla browsers which are hard coded to access the PFS will now get
redirected.  Thus, the onus is on the user to install a JVM, which suits us fine.

Explanation: the obtention of Java is best done from a *.sun.com domain.  This
way, users are always assured of obtaining the latest and greatest software.

Comment 11

14 years ago
Important caveat: comment 10 applies to Windows and Linux, and *not* to Mac OS
X.  We really don't want to direct Mac OS X users to *.sun.com for Java obtention.

Comment 12

14 years ago
Changed download URL for PFS products 10046,10047 to
http://java.sun.com/getjava/manual.html.

Updated

14 years ago
Whiteboard: [plugin]

Comment 13

14 years ago
SPAM: New Components
Assignee: aruner → english-us
Component: Plugins → English US
QA Contact: bmartin → english-us
Target Milestone: May → ---

Comment 14

14 years ago
Alex, I just did a search for a plug for java applets and still ended up at the
ftp.netscape.com locations. Can you change all references to java plugins to
point to the sun versions?

Updated

14 years ago
Summary: Get Java from http://java.sun.com/getjava instead of plugins.netscape.com → netscape.com - Get Java from http://java.sun.com/getjava instead of plugins.netscape.com

Comment 15

14 years ago
Changed download URL as requested on all plugins that refer to
application/x-java-vm MIME type.

Comment 16

14 years ago
hmm, i just searched using http://cgi.netscape.com/plugins/search_pi.html? for 

application/x-java-vm, application/x-java-applet and end up at a page with links to

http://cgi.netscape.com/cgi-bin/pi_moreinfo.cgi?PID=10047 WinXX (fetches jre
140_01i from ftp.netscape.com)

http://cgi.netscape.com/cgi-bin/pi_moreinfo.cgi?PID=10048 Linux (fetches jre
131_02 from ftp.netscape.com)

Comment 17

14 years ago
cgi.netscape.com is an obsolete location. Try http://plugins.netscape.com/search.adp

Comment 18

14 years ago
1. http://plugins.netscape.com/
2. click Find Plugins http://home.netscape.com/plugins/search_pi.html?cp=plp
3. you will be at http://wp.netscape.com/plugins/search_pi.html?cp=plp
4. search for application/x-java-vm
5. you will be at http://cgi.netscape.com/cgi-bin/pi_search.cgi with links to 

http://cgi.netscape.com/cgi-bin/pi_moreinfo.cgi?PID=10047
http://cgi.netscape.com/cgi-bin/pi_moreinfo.cgi?PID=10048

*** Bug 232423 has been marked as a duplicate of this bug. ***
*** Bug 229551 has been marked as a duplicate of this bug. ***
*** Bug 212930 has been marked as a duplicate of this bug. ***
*** Bug 211637 has been marked as a duplicate of this bug. ***
*** Bug 96251 has been marked as a duplicate of this bug. ***
What are the odds of getting the netscape.com pages changed?
Can't we at least just stop redirecting to netscape? Maybe to mozilla.org
somewhere, or directly to sun. The patch should work. If ww do that, one day all
clients will go to sun instead of netscape. Not doing anything won't fix the
problem.
(I have seen a few people on #mozillazine with a not-working xpi installed. The
linux xpi just doesn't work anymore.)

Comment 25

13 years ago
Sun seems to be promoting java.com

The page 
  http://java.sun.com/getjava/manual.html

Redirects to:
  http://www.java.com/{LANG}/download

Where {LANG} is en for me and is presumably based upon browser language settings. 

It seems to me that it would be better if people were sent to
  http://www.java.com/{LANG}/download
or
  http://www.java.com/en/download
or
  http://www.java.com


Miguel

Comment 26

12 years ago
Why is this in tech evang? It's not about evangelizing a web page to do something technically correct - it's simply a core code change (even if that piece of code is just us pointing to some URL)

We should probably be pointing to the mozilla.org plugins page for both JVM and other plugins, i.e. fix all results of http://lxr.mozilla.org/mozilla/search?string=.netscape.com%2Fplug to point to https://pfs.mozilla.org/plugins/ like we do on the about:plugins page.
Component: English US → Plug-ins
Product: Tech Evangelism → Core
Version: unspecified → Trunk

Updated

12 years ago
Assignee: english-us → nobody
QA Contact: english-us → plugins

Updated

12 years ago
Severity: enhancement → normal

Comment 27

10 years ago
This has been fixed by bug 355299
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 355299
You need to log in before you can comment on or make changes to this bug.