F6 doesn't switch focus (in a recognizable) btwn content and left pane

VERIFIED WORKSFORME

Status

SeaMonkey
Help Documentation
VERIFIED WORKSFORME
15 years ago
13 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: neil@parkwaycc.co.uk)

Tracking

({access})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
F6 doesn't switch focus in a recognizably visual fashion, when going btwn the
content and left pane. occurs on all platforms, both commercial and mozilla.

1. open the help window.
2. click on the Contents tab in the left pane.
3. click on any item, eg, "Browsing the Web" so that it's highlighted (and in
focus).
4. hit F6. this will move focus to the content pane on the right side; you'll
see a dotted outline around the content area denoting focus.
5. hit F6 again, to move focus back to the left pane.

results: the focus ring goes away from the right content pane...but now there's
no obvious indication as to where focus went.

6. hit the tab key 4 times.

results: "Browsing the Web" becomes highlighted (gets focus). it seems that
focus went to the *tabs* in the left pane. ie, at step 5, focus is on the
Glossary tab (even though it's invisible), and hitting the tab key in step 6
moves focus from there to Index, Search, Contents and finally the "Browsing the
Web" item within the Contents tab.
(Reporter)

Comment 1

15 years ago
also, it doesn't matter what theme you use.
QA Contact: tpreston → sairuh

Comment 2

15 years ago
We don't have a way of showing focus in sidebar at all, unless the sidebar panel
itself has some way of showing it.

Comment 3

15 years ago
moving stuff over to an outside-the-firewall email for the time being, looking
for people to pick these Help and doc bugs up for me.
Assignee: oeschger → oeschger

Comment 4

15 years ago
--> me

Think that this is a sidebar problem since the sidebar doesn't seem to get focus.
Assignee: oeschger → rlk

Comment 5

14 years ago
Moving to new Help component owner.
Assignee: rlk → neil.parkwaycc.co.uk
QA Contact: bugzilla → daniel.bugmail
(Assignee)

Comment 6

14 years ago
Looks fine to me in 1.8a3
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

14 years ago
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.