Extended Slashdot comments cause massive hangs, crashes, graphics corruption; on other sites as well

RESOLVED DUPLICATE of bug 32669

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 32669
15 years ago
13 years ago

People

(Reporter: captainktainer, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3) Gecko/20030312

In the example URL provided, attempting to load the page produces a hang within
the browser. External windows can still be accessed. After a wait of between
15-20 seconds, the browser becomes "unhung." However, attempts to use the
browser or to access the affected page result in severe instability and crashes.
All newly-rendered text is written in bizarre fonts; for instance, on this
computer "Star Jedi" and "Chris Pirillo" fonts frequently appear. Right-click
menus develop black borders and white bars in place of many menu items; rolling
over menu items may make some options visible (this is a handy method for
closing the affected page and restoring a modicum of stability to the browser).
Images display only as blackened silhouettes. As a final insult, unless quick
action is taken (right-clicking to close), Mozilla crashes, reporting an error
in XPICOM.dll, if I remember correctly.

This behavior is not just restricted to Slashdot; I have seen it on other sites
and regret not writing down their URLs. As I come across more examples in the
wild of crash-triggering sites I will post them here. I will install 1.4a
immediately to test if this behavior repeats; however, I will not that I have
seen it since well before 1.2.1. Apologies if this is a duplicate; I spent half
an hour searching Bugzilla and could not find a bug that accurately described my
problem.

Reproducible: Always

Steps to Reproduce:
1. Go to http://slashdot.org
2. (to be absolutely specific) Right click on any link with over 400 comments,
to be conservative
3. Wait approximately 2-3 seconds for hang.

Actual Results:  
1. Loaded
2. Right click menu works appropriately
3. Hangs and produces desktop-wide graphics irregularities- images load as black
silhouettes, backgrounds become white in color, fonts are overridden to
least-used types, crashes result.

Expected Results:  
1. Load
2. Right click menu works
3. Display page properly, after appropriate loading time.

Theme: Modern
Configuration: Windows ME, Duron 800 Mhz on VIA chipset, nVidia Geforce 3
Ti4600, 392 mB RAM.
Crash in: xpcom.xpi or xpcom.dll (will confirm crash location)

Comment 1

15 years ago
Do you happen to be a moderator on Slashdot when you see this problem?
Since you're win9x, how are your system resources when you see the problems? 
(Run Windows Resource Meter)
(Reporter)

Comment 2

15 years ago
System resources go through the roof. The bug happens whether I have mod points
or no- although it does seem marginally slower.

By the way, I'm still seeing the behavior in 1.4a now that I've upgraded. Also,
I have more information to add, in the form of a popup alert Mozilla sends to me:

"Error creating picture; you are low on system resources."

Comment 3

15 years ago
You may want to consider upgrading to a more robust OS
Low Resources is the bane of Win9x

*** This bug has been marked as a duplicate of 32669 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

15 years ago
Having read the bug this is marked as a duplicate of, I have to say that I don't
really think it's the same issue... but that's okay; maybe when that bug is
resolved this one will too. Especially since I'm 

What bugs me is that Mozilla doesn't do this on pages that are larger; I don't
get the same behavior when, for instance, the testcase for bug #32669 comes up.
In fact, my machine managed to load that one after a period of waiting, and I
managed to scroll through it, albeit slowly. Not once did I suffer graphics
corruption in that window or in other windows.

I won't reopen, though; I'll leave that to your judgement.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.