no dead keys after upgrade

RESOLVED DUPLICATE of bug 182229

Status

RESOLVED DUPLICATE of bug 182229
16 years ago
14 years ago

People

(Reporter: tiago.estima, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

I had mozilla 1.4a installed in a redhat 8.0 system working fine. I made an
upgrade from kde 3.0.x to 3.1 and now I have no dead keys in mozilla.

The relevant libs installed during the kde upgrade that I can think of are:
qt3.1,  gtk2.0 and glibc2.3.2.

I also have a mozilla 1.3 installed and the problem also occurs. 

Reproducible: Always

Steps to Reproduce:
1. Just open the composer (or in the navigator).
2. Write a dead key like á,à,é. 

Actual Results:  
I would see ´a,`a,´e

Expected Results:  
á,à,é.
Are you using a gtk2 mozilla build?

Comment 2

16 years ago
what do you see when you enter:  about:buildconfig
in the browser urlbar?
(Reporter)

Comment 3

16 years ago
I don't really know if it is a gtk2 build. I got it from mozilla.org -> 
Donwloads -> Mozilla 1.4a -> x86 tar.gz.

Requested info:

about:buildconfig

Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 2.95.3 20010315 (release) 	-Wall -W -Wno-unused 
-Wpointer-arith -Wcast-align -pedantic -Wno-long-long -g -pthread -pipe
c++ 	gcc version 2.95.3 20010315 (release) 	-fno-rtti -fno-exceptions 
-Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth 
-Wno-ctor-dtor-privacy -pedantic -Wno-long-long -g -pthread -pipe

Configure arguments
--disable-tests --enable-extensions=default,irc --without-system-nspr 
--without-system-jpeg --without-system-zlib --without-system-png 
--without-system-mng --disable-debug --enable-optimize --disable-elf-dynstr-gc 
--enable-crypto
That's a standard build.  Dead keys should work there.
(Reporter)

Comment 5

16 years ago
After the initial instalation it was fine. After the upgrade I've noticed that 
problem.

No matter what I do now (I've installed every linux version in the mozzila.org 
page) I can't get the dead keys to work again.

I don't event know what are the libs used by mozilla and which one is causing 
the problem.

Here's a silly question.  Do dead keys work in other applications?
(Reporter)

Comment 7

16 years ago
Of course!

I have dead keys in all of the following application:

Kde (all k applications)
OpenOffice
Java-based applications (Netbeans, etc...)
Many X applications like XCDRoast, etc.
Opera browser (i'm using it now and I can type á à ã â :).
Even in galleon (mozilla-based browser) I have dead-keys.


It is really strange.
Yeah, that is odd.  I don't know what you tell you.
(Reporter)

Comment 9

16 years ago
Just an aditional note. I also don't have dead keys in netscape. That makes 
sense as it is mozilla-based.

Is there any qt-based build or a static linked (gtk2) version that I can try?

Maybe there is some kind of conflict with these new libs that I've installed 
when I made the kde upgrade (using the apt-get tool).




Netscape 4.x?  Or Netscape 7.x?
(Reporter)

Comment 11

16 years ago
Netscape 7.
Are you starting these browsers up with command line arguments?
(Reporter)

Comment 13

16 years ago
No. I'm calling mozilla without arguments.

(Reporter)

Comment 14

16 years ago
I found that this bug is already reported (see Bug 182229). The problem seems to 
be the LANG enviroment variable.

If it is defined to UTF-8 the dead keys don't work (LANG=pt_PT.UTF-8)
But setting it to pt_PT will solve the problem.

Comment 15

16 years ago
resolving as duplicate per reporter

*** This bug has been marked as a duplicate of 182229 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.