importing Moz1.3 profile into Moz1.3 blows away msgFilterRules.dat

RESOLVED INCOMPLETE

Status

MailNews Core
Filters
--
major
RESOLVED INCOMPLETE
15 years ago
9 years ago

People

(Reporter: Eric Krock, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Using Moz1.3 on WinXP Pro. (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.3) Gecko/20030312)

What happened: since I was reinstalling Windows for the umpteenth time, I:
1) copied all my folders, including ...\Users\eric (my Moz user profile), to a
file server
2) had IT give me a new HDD with a clean Windows image
3) installed Moz 1.3 (same version I was using before) and opened it once in the
default profile
4) closed Moz 1.3
5) copied all my folders, including ...\Users\eric (my Moz user profile), back
from file server
6) brought up Profile Manager
7) chose to create new profile and then specified the existing user profile
directory (which seems to be the intended method of adding an existing user profile)
8) opened that restored/imported profile

EXPECTED: All properties of previous profile are the same
ACTUAL:  All properties of previous profile are the same, with the sole
exception that the profile has a clean, empty msgFilterRules.dat

I shut down Moz and copied the old msgFilterRules.dat back from the server into
the restored directory (no idea why the old one was reinitialized when Moz 1.3
imported the rest of the profile successfully) and restarted Moz 1.3, but that
didn't help; when I restarted Moz 1.3, message filters once again showed blank
(and the file was reinitialized again to 1 KB), as if Moz 1.3 was vindictively
rejecting the old data (that it itself created). ;->

This is a serious bummer as I now have to re-enter 8 pages of filter rules from
the printout (including a spam subject filter with 75 or clauses). Ouch!

See possibly-related discussion in invalid bug 185154, "Installing Mozilla 1.3
latest build over Mozilla 1.2.1 causes the msgFilterRules.dat (mail filters
folder) to dissappear"
mass re-assign.
Assignee: naving → sspitzer
Product: MailNews → Core

Comment 2

12 years ago
do you still see this problem?
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: laurel → filters
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 5

9 years ago
Going to call this incomplete - no response to comment 2 and we don't know whether msgfilterrules.dat got blown on import or on startup. And no one is going to test moz 1.3.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.