Changes in JavaScript make chat unusable

RESOLVED FIXED

Status

()

RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: fabian.seitz, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030422
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030422

This is the chat of our community, based on PHPOpenChat. Until Mozilla 1.3 it
worked fine, but with 1.4a (and the latest nightly build) the same lines are
shown over and over again. Since nothing in the code has been changed, this is
probably a JavaScript Bug. Technical background of the chat : A blind frame
reloads the page getlines.php in an endless loop. If a new line is to displayed,
they are written by this JavaScript:

function wrt(line){
 parent.output.document.write(line);
}
parent.init=0;
parent.chanchange=0;
parent.flag=0;

Reproducible: Always

Steps to Reproduce:
1. Enter the chat
2. wait a few seconds
3. Whenever a line is to be displayed, many already displayed lines come with it.




Because I haven't written the chat myself, I don't have a complete overview over
its internals. It seems to me that something is wrong with setting variables in
JavaScript. These variables seem to be important for orientation in the chat
(which lines were already written and which not).
I've set up a test account for you to check :

Username : mozillatester
Password : mozilla

Unfortunately there is no English version of the chat. Everything is in German.
Almost certainly DOM, not JS.

It's good to have the username and password, but where do I go with them?  ;)
Assignee: rogerl → dom_bugs
Component: JavaScript Engine → DOM Level 0
QA Contact: pschwartau → ashishbhatt
(Reporter)

Comment 2

16 years ago
Sorry, I forgot to post the URL
dwitte, is this a problem with cookies of some sort?
(Reporter)

Comment 4

16 years ago
it seems to be fixed in 1.4RC1 and later builds
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 5

16 years ago
whoops, I lost track of this one.

reporter: can you confirm this works in 1.4rc1? thx!

Fabian: reso/fixed isn't really appropriate here - there wasn't any patch to fix
it. worksforme would be better, but i won't bother changing it yet
(Reporter)

Comment 6

16 years ago
I am the reporter of this bug. I tested 1.4RC1 and the latest nightly build
today and in both of them the chat worked again. So I thought it is fixed.

You need to log in before you can comment on or make changes to this bug.