All dead - Mozilla no longer talking to network/internet

RESOLVED INVALID

Status

()

Core
Networking
--
blocker
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Paul D Johnson, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows 95)
Build Identifier: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.3) Gecko/20030312

There appears to be no longer any communication between Mozilla and "the 
network" on this particular networked Win95 OSR2 PC. Despite the fact that 
other browsers and mail clients work fine on the network; which is sharing a 
DSL router which acts as the internet gateway. We also have Mozilla working 
under Linux and a host of Win32 PCs on the same network. It's just this 
machine, but I cannot afford to strip it down and reinstall the O/S and the 
applications on top of it. Note that the problem occurs for Mozilla 1.0 to 1.3 
(see below).

BACKGROUND

This machine originally ran Eudora until we "went IMAP" and wanted a common 
cross-platform email application. Mozilla fits the bill great, and in fact this 
problem PC was the first Windows PC on which we tried Mozilla 1.0 when it was 
officially released. Mozilla 1.0 worked fine then. It's only when we upgraded 
it to 1.1 that it stopped working. Unfortunately uninstalling (including 
deleting the directory and other remaining files) and reverting to reinstalling 
Mozilla 1.0 did not work. Once 1.1 had been installed, it stopped it from 
working at all. We tried 1.2 when that was released, and the problem was just 
the same. Today I found the time to try 1.3 and still the same problem, hence 
this bug report.

SYMPTOMS

Browser always reports "[URL] could not be found" popup message everytime I 
enter a valid URL. Appears similar to bug 177862, though this reports 
intermittent problems only (and on Win98). I can ping a hostname (eg 
www.google.com) and have no trouble viewing the site (and others) in another 
browser such as IE5.5. I tried entering the IP address (returned from a 
successful ping) rather than the URL and it still fails to work in Mozilla, 
though the same IP address works on other browsers. So DNS appears to be fine, 
it certainly causes no problems on the rest of the network (or other apps on 
this machine). I will try to attach a PNG graphic file with a screenshot 
depicting a successful ping of google.com, followed by my lack of success with 
Mozilla to access google.com.

Mail program fails to connect to our local IMAP server with exactly the same 
settings as on other client PCs. I have double checked everything, and it fails 
to ask for the password when first connecting to the new account. It just shows 
an empty Inbox and fails to download the account folders from the IMAP server.

CONCLUSION

Hence my conclusion that Mozilla is just not talking to the network at all, 
never mind accessing the gateway router to get to the internet. Remember other 
browsers work fine. Could it be a DLL dependency somewhere? Is there a list of 
DLL dependencies for Win95 I could help you investigate?

NOTE

Why are we still running Win95? We need it as a test/development machine 
because many of our clients in the larger UK organisations are still using it.

Reproducible: Always

Steps to Reproduce:
1. Open Mozilla
2. Type in a URL.
3. Always responds with [URL] cannot be found. Please check the name and try 
again.

Actual Results:  
Popup Mozilla message "[URL] cannot be found. Please check the name and try 
again." Main window remains blank.


Expected Results:  
Accessed the URL, as other browsers on the same same PC do.

Tried all themes and many URLS. As a result of seeing bug report 177862, I 
tried the same URL many many times in succession to no avail. I will attach a 
screenshot of the error message.
(Reporter)

Comment 1

15 years ago
Created attachment 121437 [details]
Screenshot of error message

Comment 2

15 years ago
did you install 1.3 in a clean directory (or did you overwrite a previous install) ?
If still not working, does it happen with a fresh profile "mozilla
-profilemanager" ?

Updated

15 years ago
OS: other → Windows 95
-> Networking

Do you use a firewall on that system ?
Assignee: asa → darin
Component: Browser-General → Networking
QA Contact: asa → benc
(Reporter)

Comment 4

15 years ago
I confirm that I installed Mozilla 1.3 (and 1.2 and 1.1) in a clean directory. 
When it still didn't work I went one further by also attempting to clear out 
everything from the registry relating to Mozilla (and Netscape for good 
measure).

I have just tried a fresh profile as Olivier suggested, but I still have the 
same problem.
(Reporter)

Comment 5

15 years ago
In response to Matti, we use a D-Link DSL504 ADSL router which acts as our 
firewall as well as our means out onto the internet. We don't host any web 
servers or anything behind the firewall, so we have not added any additional 
rules to the base configuration.

Note that I also cannot connect to the browser interface of the router with the 
Mozilla browser, yet I can with IE5.5.
(Reporter)

Comment 6

15 years ago
Problem now resolved - though it might be useful to document somewhere?

After the reminder about the firewall, I remembered that this PC had once had
ZoneAlarm installed, though it was certainly not running _explicitly_. I found
it was still installed so I uninstalled it, rebooted and the Mozilla browser and
mail components worked fine, just as they do on the other machines.

So many thanks.
Do you see 2 loopback connections if Mozilla is started ?
netstat :
  TCP    Matti:1999             Matti:2000             HERGESTELLT
  TCP    Matti:2000             Matti:1999             HERGESTELLT
ZA is broken in several ways :-( 
Be happy that it works after the uninstall !

-> invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.