softokn3.dll crashes browser

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: webmaster0710, Assigned: asa)

Tracking

({crash, stackwanted})

Trunk
x86
Windows XP
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

Mozilla was crashing when I would click on certain web pages or click on
buttons.  I identified the culprit as "softokn3.dll"  I disabled this dll by
changing its name.  Now the browser no longer crashes, though I do get the error
message: "This application has failed to start because softokn3.dll was not found."

Important, the browser only crashed about 10% of the time when this dll is
accessed, so it is difficult to debug.

Reproducible: Sometimes

Steps to Reproduce:
1. Go to http://www.agonist.org/
2.  Or go any webpage with SLL and click on a button.
3.  Occassionally, click on a javascript button

Actual Results:  
BRowser crashes completely and must be restarted

Expected Results:  
Not crashe

Comment 1

16 years ago
did you get the Netscape Feedback Agent when crashing ? If you submitted data,
please post the associated Talkback ID here "mozilla\bin\components\talkback.exe"
Severity: normal → critical
Keywords: crash, stackwanted
Summary: softokn3.dll crashes browser → softokn3.dll crashes browser

Comment 2

16 years ago
WFM 2003042308/trunk/W2K
Reporter: Try actual nightbuild of Mozilla and try to reproduce with it.
(Reporter)

Comment 3

16 years ago
Solved is version of Moz, 1.4b.  THis version did not even install the
problematic DLL, "softokn3.dll"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 4

16 years ago
reopening as no specific patch fixed this issue.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 5

16 years ago
Forgot to mark WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.