crash on reply (only one certain message)

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: jay, Assigned: bugzilla)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

I am on Mozilla served by a Linux RH 8 server, using IMAP. The CLIENT is being
used through xwindowing run by Cygwin XFree86, running on a Windows 95 PC.

One particular plain-text email from a known correspondent is causing all
Mozilla to crash when I "Reply".  The reply composition window opens. However,
before any content becomes visible, all Mozilla crashes.  I repeated this about
eight times.

I HAVE deleted my XUL in case that was the problem.  No change. Repeated a few
more times.

I HAVE replied to other emails in the minutes before and minutes after this
problem with the specific email.

The only thing that I notice is that the email text is in very long lines when
viewed as source.  However, both viewing the source and viewing the actual
mailbox file on the server (using vi), I don't see anything unusual about it.

To my knowledge, the email does not contain any special non-ASCII characters --
if so, I can't see them.  [I have had crash problems trying to use VNC for the
xwindowing, but I have not had such problems with Cygwin.]


Reproducible: Always

Steps to Reproduce:
1. Click reply to this particular email.
2.
3.

Actual Results:  
Mozilla crashed

Expected Results:  
Should not have crashed

I will upload a copy of the email after filing this report.

I don't know how to do Talkback, etc.  If that is needed, please provide a link
to the instructions for such.

We are not planning to move to 1.3 for another couple weeks.
(Reporter)

Comment 1

16 years ago
Created attachment 121456 [details]
email (entire message and headers) that crashes my Mozilla
(Reporter)

Comment 2

16 years ago
I have also tested moving the offending email into a mailbox that has no other
messages in it.  I verified (using vi on the mailbox file) that there were no
other messages in the mailbox file.  When I click Reply, Mozilla still crashes
on this message.

In the intervening few minutes, I have sent half a dozen other messages,
forwards, and replies to multiple people and had no problems. 

The problem has only been with this message.

By the way, in my "long history" of using Netscape 4.7x on Linux, Mozilla 1.2 on
VNC (not ready for Mozilla use), and Mozilla 1.2 on Cygwin XFree86 -- 45% of the
problems I have had relate to emails from AOL, 45% from Microsoft Outlook &
Express, and 10% from everything else.  This offending message is from an AOL
user if that means anything.

Updated

16 years ago
Keywords: crash
Product: MailNews → Core

Comment 3

14 years ago
Jay Smith: Could this attached message still crash your browser? Could you
reproduce it with Mozilla 1.7.5 or Mozilla 1.8 beta or actual nightbuild? Could
 you provide Talkback incident ID in such case?
(Reporter)

Comment 4

14 years ago
Hi,

I don't have the original email still on my system.  I could theoretically copy
it from the attachment to this thread into one of my mailbox files, but if there
is something like a hidden character that was causing the problem (and now thus
is not there) the test results would be meaningless.

I did not have any problems with messages from that correspondent after that time.

I am now on 
Mozilla 1.7.3
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040914
and I have not had any similar problems in a very long time.

Also since then, quite some time ago, we have updated many linux packages (we
are still on RH8, however) including some that seem to have had some connection
with Mozilla crash and printing problems.

I think that this bug should be discontinued.  I could never make any sense of
it to start with and now way too much time has passed.  That's one way to clear
them -- wait a couple years until software/hardware changes.  :-)

Jay

Comment 5

14 years ago
Marking WFM based on reporter's last comment.
Jay, thank you for your reply.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.