assertion failure on autocomplete in debug build

RESOLVED DUPLICATE of bug 165852

Status

SeaMonkey
Location Bar
--
minor
RESOLVED DUPLICATE of bug 165852
15 years ago
9 years ago

People

(Reporter: kt, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.60 KB, text/plain
Details
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312 Netscape6/6.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312 Netscape6/6.5

Downloaded a source archive 4/22/03 and built it.
Started playing around with it, going to various websites, then this annoying
assertion box comes up.
The exact message in my console box was:
###!!! ASSERTION: non-root frame's desired size changed during an incremental re
flow: 'first == root || (aDesiredSize.width == size.width && aDesiredSize.height
 == size.height)', file c:/mozdev/mozilla/layout/html/base/src/nsPresShell.cpp,
line 915
Break: at file c:/mozdev/mozilla/layout/html/base/src/nsPresShell.cpp, line 915

The first time I visit a website (www.cnn.com) things are ok.
The next time I type in the website I get that assertion box.

No big deal really since I just ignore that box away.  But it gets kinda
annoying after a while.

Reproducible: Always

Steps to Reproduce:
1.type in www.cnn.com in address box and visit the page.
2.type in www.c in address box


Actual Results:  
assertion box pops up

Expected Results:  
no assertion box?
(Reporter)

Comment 1

15 years ago
whoops.  actual build ID:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030422
You know that you build a slow debug build ?
Can you please attach the stack trace from that assertion ?
(Reporter)

Comment 3

15 years ago
Created attachment 121470 [details]
stack trace

*** This bug has been marked as a duplicate of 165852 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.