crash installing xpi [@ js_RemoveRoot ]

RESOLVED WORKSFORME

Status

SeaMonkey
Installer
--
critical
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: Robert Ginda, Assigned: Sean Su)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Chatzilla user crashed after upgrading via an XPI.  Looks like js root
mismangement in the xpinstaller.  Stack coming up.
(Reporter)

Comment 1

15 years ago
Created attachment 121459 [details]
talkback of the crash

Updated

15 years ago
Severity: normal → critical
Keywords: crash
Summary: crash installing xpi → crash installing xpi [@ js_RemoveRoot ]

Comment 2

15 years ago
any information on how the user upgraded? what .xpi was used?  what kind of
install was on machine that was 'upgraded'? 
I cannot reproduce using a typical install and adding chatzilla.xpi

is the .xpi compatible with build?  crash during/after install or next launch?
(Reporter)

Comment 3

15 years ago
The user was installing that latest chatzilla, and the crash happend after the
install had completed.  Upon restart, the XPI was properly installed.  Every
version of chatzilla is compatible with every version of mozilla.  Beyond that,
any "incompatible" xpi should *not* crash the browser.

This looks like a memory magement problem, and is not likely to be 100%
reproducable.  There are a number of talkback reports with the same, or similar,
stack traces.  See also, bugs 175808 and 193757.
Product: Browser → Seamonkey

Comment 4

12 years ago
Robert in comment #3
> The user was installing that latest chatzilla, and the crash happend after the
> install had completed.  Upon restart, the XPI was properly installed.  Every
> version of chatzilla is compatible with every version of mozilla.  Beyond that,
> any "incompatible" xpi should *not* crash the browser.
> 
> This looks like a memory magement problem, and is not likely to be 100%
> reproducable.  There are a number of talkback reports with the same, or similar,
> stack traces.  See also, bugs 175808 and 193757.

WFM or dup to one of these bugs?
Both bug 175808 and 193757 have been closed WFM.

Comment 5

11 years ago
Going to close this as WFM per comment #4 and the fact that this bug has been untouched for over a year.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: Installer: XPI Packages → Installer
QA Contact: agracebush → general
Crash Signature: [@ js_RemoveRoot ]
You need to log in before you can comment on or make changes to this bug.