whitespace in source affects table rendering

RESOLVED INVALID

Status

()

Core
Layout: Tables
RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: Nick Pietraniec, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401

Whitespaces in HTML source code seems to be effecting table rendering.  I do
hope it's nothing stupid I'm doing but...  The following page is rendered
incorrectly

http://www.resistive.net/bugzilla/spaces.html

The following page is rendered correctly

http://www.resistive.net/bugzilla/nospaces.html

Notice the menu below the orange stripe's spacing.  It moves between the 2 files
and the only difference is the addition of white space in the source between
picture elements (see source) 

I'm having this same problem on Windows 2000 Moz 1.3, 1.4a and RedHat Linux 8
Moz 1.3, 1.4a

Reproducible: Always

Steps to Reproduce:
So...

<img> <img>

should have a space between the images.

<img><img>

Should not.  That's what's happening here. What's the bug exactly?
(Reporter)

Comment 2

16 years ago
Created attachment 121495 [details]
shows problem

I'm sorry.  it's not the best example, but it does illustrate the problem. 
I've attached a gif which hopefully points out the problem better.  I didn't
have a lot of free time to make a simplified test case, so I just posted what I
was working on.  If I have some time over the next few days I'll try to post a
better example.

Comment 3

16 years ago
i suppose there is a dup for this bug 
Whiteboard: DUPME

Comment 4

16 years ago
dup of bug 22274 ?
Ah, yes, except in reverse.  The page is using a 4.01 Transitional doctype,
which means that it's in almost-standards mode.  The only difference between
standards and almost-standards is that we have the quirky box model in
almost-standards so people don't hit bug 22274.  What that means, of course, is
that adding whitespace to the cell _will_ affect its height if the font size is
larger than the image heights...

Nick, does changing to a 4.01 Strict doctype make the two pages render identically?
Then this is all working like it's supposed to be, looks like.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Whiteboard: DUPME
You need to log in before you can comment on or make changes to this bug.