Saving bookmarks takes forever

RESOLVED INVALID

Status

RESOLVED INVALID
16 years ago
14 years ago

People

(Reporter: lassi.tuura, Assigned: bugs)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021204
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021204

Mozilla appears to write bookmark data in chunks of 4096 bytes with an immediate
fsync() afterwards (discovered from strace output).  This has disastrous
performance on a networked file system such as AFS -- any change in relatively
large collection of bookmarks takes ~10-15 seconds to make.  This measured one a
relatively modern 2.4GHz P4 box.  (Note that AFS has a local cache of most
files, and reads only relatively rarely from the server and writes data back
usually when the file is closed.  Continuously fsyncing it is terrible,
especially in 4kB chunks.)

Reproducible: Always

Steps to Reproduce:
1. Change bookmarks
2. Watch clock

Comment 1

16 years ago
1.2 is too old, please reopen if you can reproduce with 1.3 or latest nightly build.
There have been numerous bugs fixed since 1.2 on bookmarks, amongst them is bug
202477.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

16 years ago
Thanks.  I can try upgrading to 1.3 again, but last time I did that Mozilla
become too unstable for practical use and I had to revert back.  I am not sure
about the cause but I suspect everything involving Java, plug-ins and possibly
foreign data formats became unstable; unfortunately a number of pages I
frequently need to use had those, as well as some mail attachments I get. 
Perhaps I didn't install all the required RPMs -- if there is a consistent and
complete set for RH 7.3, I'd be happy to give it a try.

FWIW, with 1.2 I also see a long hang when closing browser windows.  I noticed
it did not happen with 1.3.
(Reporter)

Comment 3

16 years ago
Confirming that with 1.4a moving bookmarks is fast.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.