td are not transparent when the table has a background attribute (no tbody in XHTML)

VERIFIED FIXED

Status

()

Core
CSS Parsing and Computation
VERIFIED FIXED
15 years ago
14 years ago

People

(Reporter: Szymanski Cyrille (competitive exams, back mid May), Assigned: dbaron)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030401

See the test page at :
http://www.szym.org/table_background/table_background.xml

Each cell shows the upper left part of the table's background image when it 
should be transparent.

Reproducible: Always

Steps to Reproduce:
Confirming.  The computed style for the cells shows the background...
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Summary: td are not transparent when the table has a background attribute → td are not transparent when the table has a background attribute (no tbody in XHTML)

Comment 2

15 years ago
Note that this only happens when the background is specified in HTML.
Also, the cells will similarly "inherit" the <body> background if one isn't
specified on the table.
html.css has:

174 /* make sure backgrounds are inherited in tables  -- see bug 4510*/
175 td, th, tr {
176   background: inherit;
177 }

This was added by bernd....  and this is why the lack of a "tbody" matters. 
bernd?  Fantasai?  Is this really the desired behavior?  Should this rule be a
quirk?

Comment 4

15 years ago
That rule was moved from quirk.css to html.css as a temporary fix for Moz1.0
(We disabled standards-mode table backgrounds for 1.0 because they were wrong.)
See http://bugzilla.mozilla.org/show_bug.cgi?id=4510#c34

It will be changed back with 4510.
Depends on: 4510

Comment 5

14 years ago
Created attachment 132500 [details]
When the 'table' element has a background image

The previous case is resolved with Mozilla ver.1.5.
However, there is still similar problem when the table element has a background
image.
Please check the attachment.

Comment 6

14 years ago
-> WORKFORME
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Or rather fixed by bug 4510
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.