MIDDLE mouse click scrolling in thread pane not working

RESOLVED DUPLICATE of bug 22775

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 22775
15 years ago
13 years ago

People

(Reporter: phil, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Pressing the 3rd (third) mouse button in "Mail & Newsgroups" thread pane will
not allow scrolling. Instead it selects the message behind the mouse pointer
(duplicates the single click action).

Reproducible: Always

Steps to Reproduce:
1. Start Mozilla
2. Open Mail and Newgroups
3. Select a newsgroup or a mail folder with plenty of messages (in Folfder pane F)
4. Over the mouse somewhere in the middle of the thread pane (T)
5. Press the middle button or the wheel

-------------
|   |   T   |
|   |       |
| F |-------|
|   |   M   |
|___|_______|

Actual Results:  
6. The  message is selected and loads in the message pane (M)

Expected Results:  
5. Press the middle button or the wheel. The cursor changes to the arrows and an
image of arrows in a circle is displayed where the clicked occured.
6. Move your mouse to scroll up/down the list of messages
7. Press the middle button or the wheel to return the cursor to normal (leave
the scrolling mode).


The content of the message pane does scroll correctly with the middle-click.
No Intellipoint driver loaded on the machine.
The Middle click is working as explained in bug 70183 ("read" diamond shouldn't
toggle on middle-click)

Comment 1

15 years ago
You are asking for "AutoScroll" -- Bug 22775.  Mozilla does not have built-in 
AutoScroll for any pane or window at this time.  
See also Bug 63712 and Bug 174495.

There is an add-on module for autoscroll available at:
  http://autoscroll.mozdev.org/

*** This bug has been marked as a duplicate of 22775 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.