If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Loads extremely slow navigation app takes forever to switch compared to IE

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
RESOLVED WORKSFORME
15 years ago
7 years ago

People

(Reporter: CD Kading, Assigned: Joshua Xia)

Tracking

({perf})

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030401

The page loads very slow at http://www.asc-usi.com/ , When you try to navigate
it actually stops the browser for 10-30 seconds. I am also having the same issue
with Webmin running on my Debian Box. The file manager app takes about 2-3
minutes to load compared to 20-30 seconds in IE. Is the J2 causing this issue or
is it browser related?

Reproducible: Always

Steps to Reproduce:
1.Go to http://www.asc-usi.com/ click on the navigation bar.
2.
3.

Actual Results:  
browser stops won't respond for 30 seconds or more.

Expected Results:  
Change pages instantly like IE using Microsoft java.

Comment 1

15 years ago
*** Bug 203209 has been marked as a duplicate of this bug. ***

Comment 2

15 years ago
Java bugs go to the OJI component, not JavaScript Engine.
Java and JavaScript are different things.

This site loads 13 applets with code="fphover.class" codebase="_fpclass/".
Reassigning to OJI; note these other bugs on this type of applet:

bug 111944 "JRE 1.3.1 (01a upwards) hangs with fphover.class"
bug 176280 "browser hangs as java chokes on fphover.class"
bug 202200 "Images from 'fphover' don't load in Mozilla"


I can't confirm this report, though. Using Mozilla trunk binary
2003042308 on WinNT, the site loads quickly for me, and I can
navigate with no trouble. I'm clicking on the applets, which
are called "Home", "About us", "News", etc.

CD: what Java plug-in does Mozilla show in Help > About Plug-ins?
Mine shows Java Plug-in 1.4.1.
Assignee: rogerl → joshua.xia
Component: JavaScript Engine → OJI
Keywords: perf
QA Contact: pschwartau → dsirnapalli

Comment 3

15 years ago
what Java plug-in version do you use ?
Does it happen when upgrading to JRE 1.4.1_02 ?
Sun's JRE 1.3.x has known issues with the fphover.class applet.

Comment 4

15 years ago
Running Java 1.4.0_03 with 2003042304 on WinXP gives me a freeze on loading any
of the pages with that navigation bar.

Comment 5

15 years ago
got to get a new computer :-(
slooooooooooooow 333MHz Celeron running Java Plug-in 1.4.1_02 on Win98 with SP1
and Mozilla BuildID 2003042304
Had loaded in the background, but navigation is awful slow.

Comment 6

15 years ago
Confirming based on the above reports -
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 7

15 years ago
I can't reproduce this bug by using jre1.4.2-beta
(Assignee)

Comment 8

14 years ago
->WFM
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.