When link text is selected with the "Find in Page" (cmd-f) panel hitting return does not activate the link

RESOLVED WORKSFORME

Status

Camino Graveyard
Accessibility
--
major
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: Derek Schrock, Assigned: Brian Ryner (not reading))

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030423 Chimera/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030423 Chimera/0.7+

pre-0.7 Chimera you could us the Find in Page panel to select link text then hit
return to activate the selected link.

Reproducible: Always

Steps to Reproduce:
1. Goto the testcase
2. Open the Find in Page panel
3. Search for any of the text (ex: find, me, etc..)
4. Close the Find in Page window
Actual Results:  
Nothing

Expected Results:  
The link to be activated

If you deselect the text then Find Again (cmd-g) the correcly behavior is done
(Reporter)

Comment 1

15 years ago
Created attachment 121557 [details]
Testcase
yeah, looks like the trunk based camino (ever since early March, when we went to
the trunk) has this issue --but, oddly, nscp (moz on trunk) does not have this
problem.

brian / simon, any idea why this is occuring in only camino?
Severity: normal → major

Comment 3

15 years ago
This work for me in the 2003080802 build.

1) open find panel
2) enter text, hit find button
3) text and link are selected
4) closing the find panel
5) text and link are selected, hitting enter key goes to url

Find as you type has the same functionality as the find panel and also works
fine for me (doing a search and hitting enter key).
(Reporter)

Comment 4

15 years ago
Maybe enablng find-as-you-type fixed this. WFM.
THis bug is worksform with 2003082402.

Comment 6

15 years ago
WFM with Build ID: 2003083002, OS X 10.2.6

Comment 7

15 years ago
indeed.

resolving WFM
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.