Combining address with CSS classes and display: block; prevent following the URL

RESOLVED WORKSFORME

Status

()

Core
Event Handling
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Ilkka Tuohela, Assigned: saari (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686) Gecko/20030327 Galeon/1.3.4 Debian/1.3.3.20030419-1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030327 Galeon/1.3.4 Debian/1.3.3.20030419-1

All links, which has following CSS definations and which use the menu class, are
shown correctly but can't be followed:

A           { font-size: 10pt; text-decoration: none; }
A:link      { color: #330033; }
A:visited   { color: #005555; }
A:active    { color: #007777; }
A:hover     { color: #005555; }
                                                                               
                    
A:link.menu    { color: #e9f2fc; background-color: #5f7797; }
A:visited.menu { color: #e9f2fc; background-color: #5f7797; }
A:active.menu  { color: #007777; }
A:hover.menu   { display: block; color: #e9f2fc; background-color: #354463; }

With these definations, any link like <a class="menu" href=".....> stop working.
Removing the display: block; element allows the links to be followed.

Reproducible: Always

Steps to Reproduce:
1. Create a stylesheet with above declarations
2. Create a web page which contains a link using the name tag, for example 
   <a class="menu" href="http://www.mozilla.org/">Mozilla website</a>
3. Open the page, try to follow the link

Actual Results:  
Page is rendered correctly, but the link does not respond to clicks

Expected Results:  
The link should be opened normally

This is actually from camorama.fixedgear.org website. If you know better way to
do same visual effect, please inform the persons there so they can implement
that, currently the page has no display: block; stuff for links. I'm interested
about this bug only as a Good Citizen of OSS world ;)
Over to events; sounds like the reframe resulting from the content state change
makes the ESM mis-deliver the click....

This has come up before, and I still can't reproduce it, just like I could not
before...
Assignee: ben → saari
Component: Bookmarks → Event Handling
QA Contact: cpetersen0953 → desale

Comment 3

15 years ago
Probably dup of Bug 102578.
Doesn't look like it to me, unless bug 102578 is now describing something other
than what its original description did.

Comment 5

14 years ago
Marking WFM. If someone can still reproduce this (with a _current_ build), feel
free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.