Pressing tab button moves to next text field, but not to next radio button

VERIFIED WORKSFORME

Status

()

Firefox
General
VERIFIED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Craig, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030423 Firebird Browser/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030423 Firebird Browser/0.6

In any page with a text field and radio button or check box, pressing tab while
in the text field will skip the button/box and move to the next text field (or
the URL bar if there are no more text fields).

Reproducible: Always

Steps to Reproduce:
1. Place cursor in text field (ie, "Enter Password Here")
2. Press tab (as if moving cursor to "Submit" button)
3. Or press tab as if moving cursor to check box (ie, "Save My Password")

Actual Results:  
Cursor skips radio button/check box and moves to text field.

Expected Results:  
Hilite the next radio button or check box.

Comment 1

15 years ago
WFM with 20030424 Linux build. Do you get the same problem in Mozilla as well?

Comment 2

15 years ago
Marking WORKSFORME due to lack of response from reporter.
If more information appears later, please feel free to reopen the bug.
Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

15 years ago
It is working now on recent nightly builds.
Status: RESOLVED → CLOSED

Comment 4

15 years ago
Using Windows ME I have encountered exactly the same situation as the reporter
in all recent releases of Firebird.  Don't recall exactly when it started but it
was sometime in May or June.  

Another example:  If I post a msg to the Mozillazine Forums, and then press the
tab key, I am taken all the way to the "search" box in the lower right of the
page.  Before the problem started, the tab key would take me to the Preview
button directly under the text area, and a second press would then go to the
Submit button.

But the tab key now doesn't seem to give focus to anything that isn't a text
area or a text entry field.

Please reopen.  Thank you.

PS:  I just pressed the tab key after writing the above lines, and was taken to
the Find Bug # field at the bottom of the page.



Comment 5

15 years ago
Responding to comment #1:  The problem does not occur in two versions of Mozilla
I currently have installed, which are Composer Plus Plus from June 5 and WamCom
from June 14.

I should add that I have the problem in Firebird on 2 different computers, both
running ME.

Comment 6

15 years ago
The problem turns out to be a preference called "accessibility.tabfocus".  I
think something in the TTLO extension sets that pref.  When I went to
"about:config" and reset (actually, unset) the value in that pref, the problem
went away.

I now agree that this bug should remain closed.

Comment 7

14 years ago
Resolution CLOSED is deprecated.
Status: CLOSED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 8

14 years ago
Re-resolving as WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → WORKSFORME

Comment 9

14 years ago
Mass-verifying of former CLOSED bugs.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.