Rename Open File... to just Open...

VERIFIED WONTFIX

Status

()

Firefox
Menus
--
trivial
VERIFIED WONTFIX
15 years ago
11 years ago

People

(Reporter: Pham, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030422 Firebird™ Browser/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030422 Firebird™ Browser/0.6

Open File was neccessary with Mozilla because Mozilla had open web location.
Firebird doesn't have Open Web Location so it's useless to say Open File... when
it could just be Open... like almost every other application.

Reproducible: Always

Steps to Reproduce:
1. Go to File Menu
2.
3.

Actual Results:  
Saw Open File... unneccessarily

Expected Results:  
Have Open...

Comment 1

15 years ago
i don't think so because open... would suggest that you could open web pages as
well as files.

Comment 2

15 years ago
I agree with Will that changing Open File to Open would suggest that one could
open a URL from there, which is not the case.

Recommend WONTFIX

David, Seb?

Comment 3

15 years ago
Right indeed. Renaming to "Open..." would make sense if the dialog also
supported URL:s but since it's a local file dialog, "Open File..." sends a
clearer message.

-> WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 4

15 years ago
v
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

15 years ago
Open... has always been Open [File] as in .jpg, .gif, .png, .html, .xml
It's been a standard

Open[File]
New[Window]
Close[Window]

But since Firebird has more then one thing that it can New/Close, it needs to show
New Tab
New WIndow
Close Tab
Close Window

Why would anyone think you would open a url from Open... when it's always been
for files? 

People always assume Open... is for opening files

IE and Opera has Open... and Tools>Page Source was rejected because IE and Opera
had View>Source so why would you want to be the only app that has Open File...
and why would anyone who uses Firebird think of going to File>Open... before
going to the location bar?

>>i don't think so because open... would suggest that you could open web pages
as well as files.

You can open webpages. Or if you're talking about URLS, that's different.

The only reason why Mozilla should have Open File... is because it has two Open
commands: Web Location and File

Ben is a UI guy. He should know
Status: VERIFIED → UNCONFIRMED
Resolution: WONTFIX → ---
(Reporter)

Comment 6

15 years ago
Unless anybody can tell me what app has Open...=not Open [File] but something
else, this should be fixed
(Reporter)

Comment 7

15 years ago
http://developer.apple.com/techpubs/macosx/Essentials/AquaHIGuidelines/AHIGMenus/index.html
Open: Displays a dialog for choosing an existing document to open. 

It's always been this way and never different.

Comment 8

15 years ago
IE has Open because its Open dialog can open both files and URIs.
And many people would think of opening an URI with an "Open" dialog, since the
"Open URI" dialog has been removed.

This bug is really pointless. Having "Open File" is an useful precision which
avoids confusion, having just "Open" would only add *more* confusion (apart from
being a totally useless change).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 9

15 years ago
IE is stupid because the naturally Open... is 
Open: Displays a dialog for choosing an existing document to open.

But IE has it's own design that's stupid. I never went to IE>FILE>OPEN to
confirm that it would open a dialog that would open a document, because I
naturally assume from other apps that Open... will do that for me, and it
doesn't but that's IE's fault. IE also has this little browse button that's
barely noticable.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Reporter)

Comment 10

15 years ago
>>IE has Open because its Open dialog can open both files and URIs.

Then IE should have 2 menu items for 2 commands

>>And many people would think of opening an URI with an "Open" dialog, since the
"Open URI" dialog has been removed.

They shouldn't because Open Web Location... was called Open Web Location... and
also Open Web Location is not a popular feature and wouldn't confuse most
people(if any)

>>This bug is really pointless. Having "Open File" is an useful precision which
avoids confusion, having just "Open" would only add *more* confusion (apart from
being a totally useless change).

It would make it like most apps , excluding Mozilla and IE, which are both very
messy. 

Seb, can you pretend that "Open..." always opens a dialog to choose an exiting
document? and then users would assume ,from using a lot of apps, that Open...
would open a dialog to choose an existing document, not a non-standard OPEN URL/File

Comment 11

15 years ago
<rant>Why are you bugspamming and why are you reopening your own bugs like a
stubborn child?</rant>

It's called "Open File..." because it opens *only* filed, unlike the dialog in
IE which opens files OR uri:s. Can't you just accept that and get on with it?

Comment 12

15 years ago
Pham,

If we do what you want, you know what will happen? People who are used to IE
will start trying to open URIs through Open... and when they find that they
can't they'll go out and file a bug on it meaning David Tenser, Sébastien
Delahaye, myself and other bug triagers will be forever marking such bugs as
dupes of the first such bug, which of course will be marked WONTFIX.

Open File is a little more precise and avoids confusion. At any rate, someone
along the way decided that Open File was more desirable for whatever reason and
that is unlikely to be changed.

-->WONTFIX


More generally, please keep the number of comments down and, having triaged many
of your reports over the past few months, many of which involve naming issues
and menu placement issues such as this, I would request that you first take such
issues/concerns to the MozillaZine Firebird General forum for sounding out
(where the devs are more likely to see it anyway) and not file bug reports on
them as David, Seb and I are all getting a little tired of having to deal with
your bugs that take time away from triaging bone fide bug reports as we have to
try to figure out why things are done the way they are rather than just
determine if there is a bug in the software. Apologies for the long sentence :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 13

15 years ago
Oh. Okay. I guess I can live with Open File...
Status: RESOLVED → VERIFIED
Taking QA Contact as designated owner of Firebird-Menus. Sorry for bugspam.
QA Contact: asa → bugzilla

Updated

11 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.