Cancelling Add Account Wizard gives error message in JS console

VERIFIED FIXED

Status

SeaMonkey
MailNews: Account Configuration
--
trivial
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: Ian Neal, Assigned: Ian Neal)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

593 bytes, patch
(not reading, please use seth@sspitzer.org instead)
: review+
Details | Diff | Splinter Review
(Assignee)

Description

15 years ago
Using BuildID 2003041808 on WinXP SP1
Steps to reproduce
1. Go into MailNews
2. Select Edit, Mail & Newsgroups Account Settings
3. Click on Add Account button
4. Click on cancel

Actual Results
1. Following error message appears in JS console:
Error: gNewAccountToLoad is not defined
Source File: chrome://messenger/content/accountUtils.js
Line: 241

Expected Result
1. No error message

Fix:
Put a something along the lines of gNewAccountToLoad = null; as the first line
of the function msgOpenAccountWizard() in accountUtils.js
(Assignee)

Comment 1

15 years ago
I think this error occurs because gNewAccountToLoad is only set in
msgMail3PaneWindow.js and the function msgOpenAccountWizard() is called from
more than just the 3 Pane Window. So the declaration probably has to be done in
accountUtils.js as well. 
(Assignee)

Comment 2

15 years ago
Created attachment 121599 [details] [diff] [review]
Simple patch v1.0

Sets gNewAccountToLoad to null at beginning of msgOpenAccountWizard function
(Assignee)

Comment 3

15 years ago
Reassigning
Assignee: racham → ian
(Assignee)

Comment 4

15 years ago
Accepting, can someone review?
Status: NEW → ASSIGNED
Comment on attachment 121599 [details] [diff] [review]
Simple patch v1.0

sr=me, but have Seth take a look at this, please...

(also, does that need to be var gNewAccountToLoad? or is it already declared?)
Attachment #121599 - Flags: superreview+
Attachment #121599 - Flags: review?(sspitzer)
(Assignee)

Comment 6

15 years ago
It's declared in msgMail3PaneWindow.js, line 64 :

var gNewAccountToLoad = null;
Attachment #121599 - Flags: review?(sspitzer) → review+
fixed.  thanks ian.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
Verified FIXED; no JS errors in the console using trunk 2006-01-12-10 of SeaMonkey under Windows XP.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.