this message always crashes mozilla and thunderbird

RESOLVED WORKSFORME

Status

MailNews Core
Backend
--
critical
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: Steven Tucker, Assigned: Scott MacGregor)

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021126 Phoenix/0.4
Build Identifier: Thunderbird and current mozilla nightly

segfault every time its viewed or deleted

Reproducible: Always

Steps to Reproduce:
1. place in maildir
2. open maildir
3. click message

Actual Results:  
crash, no module name displayed

Expected Results:  
display message

message saved in zip file at http://www.atarimax.com/crashmessage.zip

mail was stored in maildir format, served over IMAP connection by courier-imap.
(Reporter)

Comment 1

15 years ago
Created attachment 121614 [details]
message that causes crash, zipped directly from maildir

Comment 2

15 years ago
I'm unable to display your message in Mozilla Mail (2003042208).

BTW could you provide talkback incident ID?
Keywords: crash
(Reporter)

Comment 3

15 years ago
Many spam e-mail seem to contain null character (ascii zero) that causes
mozilla/thunderbird to either crash, or be unable to delete the e-mail off the
imap server.

Comment 4

14 years ago
unable to reproduce with mozilla 1.7 beta. if you can reproduce this with 1.7
beta or newer talkback enabled build, please reopen with a talkback ID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.