HPUX build using 10.20 gtk 1.2.6 libs doesn't run

VERIFIED DUPLICATE of bug 20153

Status

()

Core
XUL
P1
critical
VERIFIED DUPLICATE of bug 20153
19 years ago
19 years ago

People

(Reporter: Jim Dunn, Assigned: Jim Dunn)

Tracking

Trunk
HP
HP-UX
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

19 years ago
running the hpux 10.20 viewer build with 'shared' gtk libraries
I get the following output:

...
Going to create the event queue
GFX: dpi=96 t2p=0.0666667 p2t=15 depth=24Gdk-ERROR **: BadMatch (invalid
parameter attributes)
  serial 348 error_code 8 request_code 66 minor_code 0

aborting...
Abort(coredump)
(Assignee)

Updated

19 years ago
Blocks: 18687
(Assignee)

Updated

19 years ago
Priority: P3 → P1
(Assignee)

Comment 1

19 years ago
on HP 11.00 the trace back is as follows

#0  0x7aff0948 in kill () from /usr/lib/libc.2
#1  0x7af8a7e8 in raise () from /usr/lib/libc.2
#2  0x7afce690 in abort_C () from /usr/lib/libc.2
#3  0x7afce714 in abort () from /usr/lib/libc.2
#4  0x4569c in g_logv ()
#5  0x7aa39304 in g_error () from /u/jdunn/tools/share/lib/libgdk-1.2.sl.5
#6  0x7aa3bfe4 in gdk_x_error () from /u/jdunn/tools/share/lib/libgdk-1.2.sl.5
#7  0x7ab152f4 in _XError () from /usr/lib/libX11.3
#8  0x7ab13324 in _XReply () from /usr/lib/libX11.3
#9  0x7aaef718 in XListFonts () from /usr/lib/libX11.3
#10 0x79d7d888 in GetFontNames (aPattern=0x7b041cc4
"-*-courier-*-*-*-*-*-*-*-*-*-*-*-*") at nsFontMetricsGTK.cpp:1957
#11 0x79d7ed08 in nsFontMetricsGTK::FindFont (this=0x40266fc0, aChar=97) at
nsFontMetricsGTK.cpp:2285
#12 0x79d798e8 in nsFontMetricsGTK::Init (this=0x40266fc0, aFont=@0x7b041910,
aContext=0x40250078) at nsFontMetricsGTK.cpp:158
#13 0x7a380e50 in nsFontCache::GetMetricsFor (this=0x40266e78,
aFont=@0x7b041910, aMetrics=@0x7b0419e0) at nsDeviceContext.cpp:675
#14 0x7a37f380 in DeviceContextImpl::GetMetricsFor (this=0x40250078,
aFont=@0x7b041910, aMetrics=@0x7b0419e0) at nsDeviceContext.cpp:240
#15 0x79d85ba4 in nsRenderingContextGTK::SetFont (this=0x40266d10,
aFont=@0x7b041910) at nsRenderingContextGTK.cpp:531
#16 0x2cf70 in nsThrobber::HandleThrobberEvent (aEvent=0x7b0416a0) at
nsThrobber.cpp:143
#17 0x79e4e688 in nsWidget::DispatchEvent (this=0x4024f2a8, aEvent=0x7b0416a0,
aStatus=@0x7b041760) at nsWidget.cpp:1389
#18 0x79e4e060 in nsWidget::DispatchWindowEvent (this=0x4024f2a8,
event=0x7b0416a0) at nsWidget.cpp:1280
#19 0x79e55310 in nsWindow::DoPaint (this=0x4024f2a8, aX=588, aY=0, aWidth=32,
aHeight=32, aClipRegion=0x4024f3e0) at nsWindow.cpp:335
#20 0x79e5542c in nsWindow::Update (this=0x4024f2a8) at nsWindow.cpp:353
#21 0x79e55834 in nsWindow::Invalidate (this=0x4024f2a8, aIsSynchronous=1) at
nsWindow.cpp:448
#22 0x2dfd0 in nsThrobber::LoadThrobberImages (this=0x4024f178,
aFileNameMask=@0x7b040bfc, aNumImages=29) at nsThrobber.cpp:364
#23 0x2d8f0 in nsThrobber::Init (this=0x4024f178, aParent=0x401702d8,
aBounds=@0x7b040c24, aFileNameMask=@0x7b040bfc, aNumImages=29) at
nsThrobber.cpp:230
#24 0x22134 in nsBrowserWindow::CreateToolBar (this=0x40170180, aWidth=620) at
nsBrowserWindow.cpp:1425
#25 0x21128 in nsBrowserWindow::Init (this=0x40170180, aAppShell=0x40164cb8,
aPrefs=0x400aab50, aBounds=@0x7b040678, aChromeMask=4294967295, aAllowPlugins=1)
at nsBrowserWindow.cpp:1212
#26 0x31554 in nsViewerApp::OpenWindow (this=0x40047e68) at nsViewerApp.cpp:686
#27 0x39638 in nsNativeViewerApp::Run (this=0x40047e68) at nsGtkMain.cpp:48
#28 0x39b40 in main (argc=1, argv=0x7b04044c) at nsGtkMain.cpp:166
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M12
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

19 years ago
dup of
http://bugzilla.mozilla.org/show_bug.cgi?id=20153

NOTE the fix is in the following
http://bugzilla.mozilla.org/show_bug.cgi?id=19263

*** This bug has been marked as a duplicate of 20153 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 3

19 years ago
VERIFIED dupe
You need to log in before you can comment on or make changes to this bug.