Browser crashes upon viweing of this page

VERIFIED FIXED in M13

Status

()

P2
blocker
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: belg4mit, Assigned: eric)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
I have included the location of an archive contaning a page that
appears to infallibly cause m11 to crash.
The offending page is logonskin.html

Updated

19 years ago
Component: Browser-General → Layout
QA Contact: leger → petersen

Comment 1

19 years ago
Updating QA Contact.

Comment 2

19 years ago
I can reproduce the problem in the Dec 06th build. Report has been generated in
Talkback ID 1991066.

Comment 3

19 years ago
Here's the call stack:


 Call Stack:    (Signature = nsInfoListImpl::SanityCheck 5d381096)

   nsInfoListImpl::SanityCheck
                                                              [d:\builds\
seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 2552]

   nsBoxFrameInner::SanityCheck
                                                              [d:\builds\
seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 2331]

   nsBoxFrame::Reflow
                                                              [d:\builds\
seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 472]

   nsContainerFrame::ReflowChild
                                                              [d:\builds\
seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 628]

   nsGfxScrollFrameInner::ReflowFrame
                                                              [d:\builds\
seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 1197]

   nsGfxScrollFrameInner::ReflowScrollbar
                                                              [d:\builds\
seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 1066]

   nsGfxScrollFrameInner::ReflowScrollbars
                                                              [d:\builds\
seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 1014]

   nsGfxScrollFrame::Reflow
                                                              [d:\builds\
seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 460]

   nsContainerFrame::ReflowChild
                                                              [d:\builds\
seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 628]

   ViewportFrame::Reflow
                                                              [d:\builds\
seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line 527]

   PresShell::StyleChangeReflow
                                                              [d:\builds\
seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 1352]

   nsPresContext::PreferenceChanged
                                                              [d:\builds\
seamonkey\mozilla\layout\base\src\nsPresContext.cpp, line 249]

   PrefChangedCallback
                                                              [d:\builds\
seamonkey\mozilla\layout\base\src\nsPresContext.cpp, line 55]

   pref_DoCallback
                                                              [d:\builds\
seamonkey\mozilla\modules\libpref\src\prefapi.c, line 2302]

   pref_HashPref
                                                              [d:\builds\
seamonkey\mozilla\modules\libpref\src\prefapi.c, line 1873]

   PREF_SetCharPref
                                                              [d:\builds\
seamonkey\mozilla\modules\libpref\src\prefapi.c, line 721]

   nsPref::SetFilePref
                                                              [d:\builds\
seamonkey\mozilla\modules\libpref\src\nsPref.cpp, line 882]

   nsStreamTransfer::SelectFile
                                                              [d:\builds\
seamonkey\mozilla\xpfe\components\xfer\src\nsStreamTransfer.cpp, line 183]

   nsStreamTransfer::SelectFileAndTransferLocation
                                                              [d:\builds\
seamonkey\mozilla\xpfe\components\xfer\src\nsStreamTransfer.cpp, line 80]

   nsStreamTransfer::SelectFileAndTransferLocationSpec
                                                              [d:\builds\
seamonkey\mozilla\xpfe\components\xfer\src\nsStreamTransfer.cpp, line 125]

   XPTC_InvokeByIndex
                                                              [d:\builds\
seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp, line 139]

   nsXPCWrappedNativeClass::CallWrappedMethod
                                                              [d:\builds\
seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativeclass.cpp, line 895]

   WrappedNative_CallMethod
                                                              [d:\builds\
seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp, line 192]

   js_Invoke
                                                              [d:\builds\
seamonkey\mozilla\js\src\jsinterp.c, line 666]

   js_Interpret
                                                              [d:\builds\
seamonkey\mozilla\js\src\jsinterp.c, line 2227]

   js_Invoke
                                                              [d:\builds\
seamonkey\mozilla\js\src\jsinterp.c, line 686]

   js_Interpret
                                                              [d:\builds\
seamonkey\mozilla\js\src\jsinterp.c, line 2227]

   js_Invoke
                                                              [d:\builds\
seamonkey\mozilla\js\src\jsinterp.c, line 686]

   js_InternalCall
                                                              [d:\builds\
seamonkey\mozilla\js\src\jsinterp.c, line 759]

   JS_CallFunctionValue
                                                              [d:\builds\
seamonkey\mozilla\js\src\jsapi.c, line 2754]

   nsJSContext::CallFunctionObject
                                                              [d:\builds\
seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 544]

   nsJSEventListener::HandleEvent
                                                              [d:\builds\
seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 129]

   nsEventListenerManager::HandleEventSubType
                                                              [d:\builds\
seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line 635]

   nsEventListenerManager::HandleEvent
                                                              [d:\builds\
seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line 774]

   nsXULElement::HandleDOMEvent
                                                              [d:\builds\
seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 2679]

   nsEventStateManager::CheckForAndDispatchClick
                                                              [d:\builds\
seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 1407]

   nsEventStateManager::PostHandleEvent
                                                              [d:\builds\
seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 640]

   PresShell::HandleEvent
                                                              [d:\builds\
seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2522]

   nsView::HandleEvent
                                                              [d:\builds\
seamonkey\mozilla\view\src\nsView.cpp, line 841]

   nsViewManager::DispatchEvent
                                                              [d:\builds\
seamonkey\mozilla\view\src\nsViewManager.cpp, line 1678]

   HandleEvent
                                                              [d:\builds\
seamonkey\mozilla\view\src\nsView.cpp, line 69]

   nsWindow::DispatchEvent
                                                              [d:\builds\
seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 425]

   nsWindow::DispatchWindowEvent
                                                              [d:\builds\
seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 442]

   nsWindow::DispatchMouseEvent
                                                              [d:\builds\
seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3340]

   ChildWindow::DispatchMouseEvent
                                                              [d:\builds\
seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3556]

   nsWindow::ProcessMessage
                                                              [d:\builds\
seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2650]

   nsWindow::WindowProc
                                                              [d:\builds\
seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 609]

   KERNEL32.DLL + 0x363b (0xbff7363b)


   KERNEL32.DLL + 0x242e7 (0xbff942e7)


   0x00638c3e

Updated

19 years ago
Assignee: leger → troy

Comment 4

19 years ago
Updating engineer...shouldn't be me :-)

Updated

19 years ago
Assignee: troy → evaughan

Comment 5

19 years ago
Looks to be box related

Updated

19 years ago
Priority: P3 → P2
Target Milestone: M13

Comment 6

19 years ago
still crashes in 12/8 opt comm bits. assigning to evaughan as p2 for m13
Why is this bug marked a blocker?  What mozilla development work is it blocking?

Comment 7

19 years ago
This bug works for me on Win95 build 1999121712 - but the crash page in the URL
and the call stack in the description make it look a lot like bug# 22026 which
still crashes.  Perhaps these are related?
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

19 years ago
With todays build this works fine, no crashes.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 9

19 years ago
With the Dec 22nd build (1999122208), this problem has been fixed.
You need to log in before you can comment on or make changes to this bug.