Crash sending e-mail after changing email address in Account Settings

VERIFIED DUPLICATE of bug 197203

Status

MailNews Core
Composition
--
critical
VERIFIED DUPLICATE of bug 197203
16 years ago
10 years ago

People

(Reporter: Doug Chan, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3) Gecko/20030319
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3) Gecko/20030319

The email client crashes upon sending a message if the e-mail
address is set to some invalid format (such as 'dchan AT foo.com').

Not sure which component this bug goes under...
Could be Networking-SMTP or Mail Windor Front End?

Reproducible: Always

Steps to Reproduce:
1.Bring up a the Mail/News client
2. Go to Edit > Mail & Newsgroups Account Settings
3. Select your mail account (left panel)
4. In the Email Address, change it to something like 'me AT domain.com'.
5. Select OK

6.  Compose a test message, address it to yourself, hit send.
The client crashes here.

Actual Results:  
Client exits / crashes.

Expected Results:  
Either accept the string as it is (unchecked) or validate that it is
in a mail-to URL format?

*** This bug has been marked as a duplicate of 197203 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.