Closed Bug 203420 Opened 18 years ago Closed 18 years ago

Text in standalone message window switches to grey rendering

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 54570

People

(Reporter: potterveld, Assigned: sspitzer)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

A single line in the message text consisting of two dashes and a space will
switch the rendering to grey for all following text. This is especially
bothersome for reading mailing list digests where such lines commonly separate
signatures, causing most of the digest to re rendered in grey. Sometimes,
it will pop back to normal following a section of ">" quoted text.

Reproducible: Always

Steps to Reproduce:
1. Cut and paste the following text into a new message and save it in
a message in the local drafts folder:

This line will be rendered normally.
-- 
These lines are rendered in gray, apparently because of the
preceeding line (two dashes and a space).

2. Copy the saved message to the local inbox folder.
3. Display the message in a standalone window.
Actual Results:  
The first line is rendered normally (in black.)
The lines following and including the "-- " line are rendered in grey.

Expected Results:  
All lines should have been rendered normally (in black.)

*** This bug has been marked as a duplicate of 54570 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.